Support transparency

Bug #804901 reported by Avi Romanoff on 2011-07-02
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Terminal
Fix Released
Wishlist
David Gomes

Bug Description

The current white/gray combo might work for some, but it's pretty hard on the eyes for colored output. The ability to have a transparent background, with any color, and have the text be any color, is a staple feature of just about any terminal client.

Avi, I think the color combo is (going to be?) set by the GTK theme for dark apps. Instead of changing it, I think the color output should be looked at/tweaked if possible (as the current color of blue used for output, ex. in "ls", is pretty terrible to read).

Also, from what I can tell from mockups, the idea is for the titlebar (which will be dark for dark GTK apps) and the rest of the window to blend together, but if just the text area is translucent, it wouldn't blend as well.

Avi Romanoff (aroman) wrote :

I see what you're saying, but I think the option needs to be there in the preferences dialog. Obviously, the default will be set to whatever. About transparency, I don't see how that's an issue since the terminal text area can be painted upon by terminal programs, so you would lose the color matching entirely and you can't do anything about that.

David Gomes (davidgomes) on 2011-12-05
Changed in pantheon-terminal:
importance: Undecided → Wishlist
status: New → Confirmed
David Gomes (davidgomes) on 2011-12-18
Changed in pantheon-terminal:
milestone: none → 0.2
David Gomes (davidgomes) on 2011-12-18
Changed in pantheon-terminal:
assignee: nobody → David Gomes (davidgomes)
milestone: 0.2 → 0.1
status: Confirmed → Fix Committed
Matthew Markell (markellmtthw) wrote :

I would like to have true transparency like gnome-terminal, where I can see windows below the terminal.

Daniel Fore (danrabbit) on 2012-07-26
Changed in pantheon-terminal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers