Transparency not functional in latest version of pantheon-terminal [0.2.4.1] even with compositing WM (Gala)

Bug #1260383 reported by le best pone on 2013-12-12
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Terminal
Invalid
Undecided
Unassigned
elementary Stylesheet
Fix Released
Undecided
Daniel Fore

Bug Description

This issue was experienced while using Gala with Xfce and running Pantheon-Terminal on Arch Linux. Apparently it had worked at one point, according to the pantheon-terminal packager (alucryd), but it no longer works: upon startup, it is very briefly properly transparent before it reverts to a black background which is *not* the color set in gsettings for the background.

The attached screenshot (supposedly) has a background of #2d2d2d and 50% opacity in dconf, yet it is not appearing that way.

Niclas Lockner (niclasl) wrote :

I have a similar experience as you, but for me it seems that it isn't caused by Pantheon Terminal, but Gala.
For me, transparency works in both gnome-terminal and pantheon-terminal when using Unity, but neither of them work as expected when using Gala. (This is with gala and pantheon-terminal from the daily ppa under Ubuntu 13.10, so it's not the same setup as yours).

Does e.g. gnome-terminal's transparency work with Gala for you? And does pantheon-terminal's transparency work with some other WM?

Hey. Sorry for the late response - tested also when using GNOME Shell/Mutter, but transparency still doesn't work. Note: If I go to the "about" screen, it works perfectly - turns black again upon closing it. Probably not a Gala problem.

Daniel Fore (danrabbit) on 2014-04-13
Changed in pantheon-terminal:
status: New → Invalid
Changed in egtk:
status: New → Fix Committed
milestone: none → isis-beta1
assignee: nobody → Daniel Fore (danrabbit)
Daniel Fore (danrabbit) on 2014-05-25
Changed in egtk:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers