control-q does not generate any response

Bug #1080982 reported by dan hitt on 2012-11-20
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Terminal
Fix Released
Medium
David Gomes

Bug Description

This is on Pantheon Terminal 0.1 (as reported by /usr/bin/pantheon-termin --version) using the 2012-11-14 release (beta 1) of ElementaryOS.

Typing control-q (that is, holding down the control key and then typing q) does not appear to have any effect.

This is evident in emacs (run via emacs -nw).

If you open a buffer, and type control-x control-q, which should normally toggle its read-only status, you only get the control-x character.

In fact, control-q is a sort of important character in emacs, as you use it to quote things.

Although it is possible to work around this in emacs, using fully spelled out command names, it would be very useful if control-q worked.

(Note that other control keys do work, and xev confirms that both control and q are working separately.)

Thanks in advance for any fix.

David Gomes (davidgomes) on 2012-11-22
Changed in pantheon-terminal:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → luna-beta2
David Gomes (davidgomes) on 2013-01-04
Changed in pantheon-terminal:
assignee: nobody → David Gomes (davidgomes)
status: Confirmed → In Progress
Cody Garver (codygarver) on 2013-01-04
Changed in pantheon-terminal:
status: In Progress → Fix Released
David Gomes (davidgomes) on 2013-01-04
Changed in pantheon-terminal:
status: Fix Released → Fix Committed

(a) Thanks David (and/or Cody) for the fix.

(b) What do i need to do to get the fix? I did:
      sudo apt-get install pantheon-terminal
     This generated some activity.

     I then did "dpkg -s pantheon-terminal" and got
     a version number of 0.1-0~r423+pkg10~precise1

     But the behavior seems unchanged.

(Or maybe i'm updating prematurely?)

Thanks in advance for any info, and thanks again for figuring out and
fixing the bug.

dan

On Fri, Jan 4, 2013 at 3:08 PM, David Gomes <email address hidden> wrote:
> ** Changed in: pantheon-terminal
> Status: Fix Released => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1080982
>
> Title:
> control-q does not generate any response
>
> Status in Pantheon Terminal:
> Fix Committed
>
> Bug description:
> This is on Pantheon Terminal 0.1 (as reported by /usr/bin/pantheon-
> termin --version) using the 2012-11-14 release (beta 1) of
> ElementaryOS.
>
> Typing control-q (that is, holding down the control key and then
> typing q) does not appear to have any effect.
>
> This is evident in emacs (run via emacs -nw).
>
> If you open a buffer, and type control-x control-q, which should
> normally toggle its read-only status, you only get the control-x
> character.
>
> In fact, control-q is a sort of important character in emacs, as you
> use it to quote things.
>
> Although it is possible to work around this in emacs, using fully
> spelled out command names, it would be very useful if control-q
> worked.
>
> (Note that other control keys do work, and xev confirms that both
> control and q are working separately.)
>
> Thanks in advance for any fix.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pantheon-terminal/+bug/1080982/+subscriptions

dan hitt (dan-hitt) wrote :

The fix works, and thanks again David (and/or Cody).

In case anybody else is doing a search and comes across this thread, the update manager notified me that i had a bunch of packages to update, and after i consented, it wanted the machine to be restarted.

After the restart, control-q worked.

This makes emacsing much more convenient on ElementaryOS.

David Gomes (davidgomes) on 2013-03-09
Changed in pantheon-terminal:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers