Create a plug for Plank

Bug #754839 reported by Danielle Foré
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Pantheon Plugs
Fix Released
Undecided
Mario Guerriero

Bug Description

Since Plank is part of the "desktop itself" and not really an app, so to speak, we should have a plug for it's basic configuration in switchboard.

I would really prefer to see this plug shipped with plank (so that in case plank is removed the plug is also removed), but if Robert doesn't want to support switchboard we'll probably want to ship this plug anyways.

Robert Dyer (psybers)
Changed in plank:
importance: Undecided → Wishlist
Revision history for this message
Danielle Foré (danrabbit) wrote :

After discussion with Robert in IRC we decided the best thing to do would be to create a package like "switchboard-plank" that plank would recommend and that would depend on plank. In this way, a user who doesn't use plank doesn't get this package, and a user that doesn't use switchboard doesn't have to install it either.

Revision history for this message
Avi Romanoff (aroman) wrote :

Sounds fine by me, who would write said package/plug?

Revision history for this message
Danielle Foré (danrabbit) wrote :

That would be us :p

Avi Romanoff (aroman)
Changed in switchboard:
status: New → Confirmed
Avi Romanoff (aroman)
Changed in elementaryos:
status: New → Confirmed
importance: Undecided → Medium
milestone: none → luna-alpha1
tags: added: deb iso packaging switchboard
Changed in switchboard:
status: Confirmed → Won't Fix
Robert Dyer (psybers)
Changed in plank:
status: New → Invalid
Changed in elementaryos:
status: Confirmed → Invalid
Changed in pantheon-plugs:
status: New → Confirmed
Revision history for this message
Mario Guerriero (mefrio-g) wrote :

You can see a first implementation of the plank plug here: lp:~mefrio-g/+junk/plank-plug

Revision history for this message
Robert Dyer (psybers) wrote :

Just a thought, but since Plank is obviously installed why not use it's library in your plug? You can probably reuse our classes for reading/writing the preferences, which might make things a bit easier (as if we change how we do things in the future, your plug would just get those changes for free).

Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Great idea IMHO! Especially since Plank plug will depend on Plank anyway.

Changed in pantheon-plugs:
assignee: nobody → Mario Guerriero (mefrio-g)
Changed in switchboard:
status: Won't Fix → Invalid
Changed in pantheon-plugs:
status: Confirmed → Fix Committed
no longer affects: elementaryos
Robert Dyer (psybers)
no longer affects: plank
Changed in pantheon-plugs:
milestone: none → luna-beta1
Revision history for this message
Sergey "Shnatsel" Davidoff (shnatsel) wrote :

Appearance plug in PPA also handles Plank.

Cody Garver (codygarver)
no longer affects: switchboard
Changed in pantheon-plugs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints