Create a User Accounts plug [$340]

Bug #711611 reported by Daniel Fore
44
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Pantheon Plugs
Fix Released
Wishlist
Marvin Beckers

Bug Description

A user accounts plug should be created that can:

- Create accounts
- Remove accounts
- Edit a user's first and last name
- Set a user's avatar
- Add a user to Dexter automagically
- Open a user's contact data in Dexter
- Set a user's account type
- Change a user's password
- Enable/disable the guest account

I've attached a mockup of what this might look like.

Revision history for this message
Daniel Fore (danrabbit) wrote :
Changed in switchboard:
status: New → Won't Fix
status: Won't Fix → Invalid
Cody Garver (codygarver)
Changed in pantheon-plugs:
status: New → Triaged
importance: Undecided → Wishlist
tags: added: future
Cody Garver (codygarver)
tags: added: need-new-plug
Cody Garver (codygarver)
no longer affects: switchboard
Cody Garver (codygarver)
Changed in pantheon-plugs:
milestone: none → isis-beta1
status: Triaged → Confirmed
Revision history for this message
Cameron Norman (cameronnemo) wrote :

Hey Daniel, I was thinking of taking a crack at this. Do you want to update the mockup at all, or are there any tweaks you would like to make?

Cody Garver (codygarver)
Changed in pantheon-plugs:
milestone: isis-beta1 → isis+1-beta1
Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

From a quick glance, I'd say use the more common GTK3-style add/remove toolbar at the bottom of the left pane. Which would mean you could likely remove the "Remove account" and "New account" parts.

I'm also not sure how the cancel/save buttons factor in here. Perhaps we default to a read-only sort of view and have an icon in the bottom left toolbar (next to the add/remove) and then have an info bar with a save button while editing?

Feedback from Dan is welcome. ;)

Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

Derp, I accidentally some words.

*Perhaps we default to a read-only sort of view, have an edit icon in the bottom left toolbar (next to the add/remove), and then have an info bar with a save button while editing?

Revision history for this message
Daniel Fore (danrabbit) wrote :

Okay here's a new design.

I've excluded features to do with contact editing/viewing since we're currently not shipping a contacts manager.

Revision history for this message
Ezra Sharp (nicekiwi) wrote :

Could be a good first project! :D

Revision history for this message
Ezra Sharp (nicekiwi) wrote :

What account types are there?

The difference between User and Admin on *nix is the ability to use the 'sudo' command, am I right?

Revision history for this message
opensas (opensas) wrote :

What happens if a user belongs to several groups? can't see how to work with that scenario in the UI mocks... Should have an option to add and remove groups...

Revision history for this message
Daniel Fore (danrabbit) wrote : Re: Create a User Accounts plug [$300]
summary: - Create a User Accounts plug
+ Create a User Accounts plug [$300]
tags: added: bounty
Changed in pantheon-plugs:
status: Confirmed → In Progress
assignee: nobody → Tom Beckmann (tombeckmann)
Daniel Fore (danrabbit)
summary: - Create a User Accounts plug [$300]
+ Create a User Accounts plug [$335]
Revision history for this message
Robert Roth (evfool) wrote : Re: Create a User Accounts plug [$335]

@Tom Beckmann: Are you still working on this?

Revision history for this message
Tom Beckmann (tombeckmann) wrote :

Yes I am, in two weeks I will have finished my final exams at which point I'll be able to finish the code.

Revision history for this message
Robert Roth (evfool) wrote :

Could you please share your thoughts on the add user workflow (should it pop up a dialog, if yes, what fields should appear there, if not, should it be inline in the plug? e.g. by temporarily adding a password confirm entry)? What about changing the user picture? Could we use a Gtk.PopOver there?

summary: - Create a User Accounts plug [$335]
+ Create a User Accounts plug [$340]
Revision history for this message
Ezra Sharp (nicekiwi) wrote :

Would be nice to be able to change the username too. In case of typos during installation.. <_<

Daniel Fore (danrabbit)
Changed in pantheon-plugs:
assignee: Tom Beckmann (tombeckmann) → Marvin Beckers (embik)
Revision history for this message
Sam Hewitt (snwh) wrote :

Such an outstanding bug, here's an updated mockup.

Daniel Fore (danrabbit)
Changed in pantheon-plugs:
status: In Progress → Fix Released
milestone: loki-beta1 → freya-beta2
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Related blueprints