Move View menu to background Context menu

Bug #1275114 reported by Daniel Fore on 2014-01-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Photos
Fix Released
Wishlist
Robert Roth

Bug Description

Right clicking the grid view's background should show everything that is currently in the "view" menu, plus "select all"

Related branches

Daniel Fore (danrabbit) on 2014-02-20
tags: added: bitesize
Robert Roth (evfool) wrote :

What would happen to the Grid views' background that already have a context menu (e.g on Tags or Trash)? Would the view menu added after the existing menuitems, after a separator?
Or should it only be added where there's no context menu?

Changed in pantheon-photos:
assignee: nobody → Daniel Fore (danrabbit)
status: New → Incomplete
Robert Roth (evfool) wrote :

Dan, any thoughts on comment #1?

Daniel Fore (danrabbit) wrote :

Thanks for bumping the report Robert!

We can probably replace the ones on tags and trash since they're a duplicate of the menu you get in the sidebar

Changed in pantheon-photos:
assignee: Daniel Fore (danrabbit) → nobody
status: Incomplete → Confirmed
Robert Roth (evfool) on 2014-05-22
Changed in pantheon-photos:
assignee: nobody → Robert Roth (evfool)
status: Confirmed → In Progress
RabbitBot (rabbitbot-a) on 2014-05-24
Changed in pantheon-photos:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2014-06-22
Changed in pantheon-photos:
milestone: none → freya-beta1
Daniel Fore (danrabbit) on 2014-12-29
Changed in pantheon-photos:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints