user icon scaling is ugly

Reported by Pim Vullers on 2012-01-11
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Greeter
Undecided
Kiran Hampal

Bug Description

When the greeter is started the user icons zoom into view. For this the 96x96 pixel icons provided by accountsservice are used. However the image displayed in the end is larger. For me this results in a small sharp/clear starting icon which grows in size when zooming into view. However when it grows it gets 'blocked' like it is just very large pixels. In the end (after approx. 1 second) the image has been rendered/scaled properly again and it looks a little blurry/vague but much better then the 'blocked' icon.

I don't know if this is a pantheon-greeter issue or whether it's due to webkit(-greeter). But I hope this can be improved somehow.

(This is on a mobile Core i7 system so I'd say it's not caused by a slow system.)

This is probably both, webkit beeing buggy as well as accountservice
providing only small icons
Am 11.01.2012 10:17 schrieb "Pim Vullers" <email address hidden>:

> Public bug reported:
>
> When the greeter is started the user icons zoom into view. For this the
> 96x96 pixel icons provided by accountsservice are used. However the
> image displayed in the end is larger. For me this results in a small
> sharp/clear starting icon which grows in size when zooming into view.
> However when it grows it gets 'blocked' like it is just very large
> pixels. In the end (after approx. 1 second) the image has been
> rendered/scaled properly again and it looks a little blurry/vague but
> much better then the 'blocked' icon.
>
> I don't know if this is a pantheon-greeter issue or whether it's due to
> webkit(-greeter). But I hope this can be improved somehow.
>
> (This is on a mobile Core i7 system so I'd say it's not caused by a slow
> system.)
>
> ** Affects: pantheon-greeter
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of
> elementary Pantheon team, which is the registrant for Pantheon Login
> Screen.
> https://bugs.launchpad.net/bugs/914646
>
> Title:
> user icon scaling is ugly
>
> Status in Pantheon Login Screen:
> New
>
> Bug description:
> When the greeter is started the user icons zoom into view. For this
> the 96x96 pixel icons provided by accountsservice are used. However
> the image displayed in the end is larger. For me this results in a
> small sharp/clear starting icon which grows in size when zooming into
> view. However when it grows it gets 'blocked' like it is just very
> large pixels. In the end (after approx. 1 second) the image has been
> rendered/scaled properly again and it looks a little blurry/vague but
> much better then the 'blocked' icon.
>
> I don't know if this is a pantheon-greeter issue or whether it's due
> to webkit(-greeter). But I hope this can be improved somehow.
>
> (This is on a mobile Core i7 system so I'd say it's not caused by a
> slow system.)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pantheon-greeter/+bug/914646/+subscriptions
>

Fabian Thoma (agent00tai) wrote :

Yeah I can confirm that this is too small images, it looks much better with decent sized images

Changed in pantheon-greeter:
milestone: none → luna-beta1
Changed in pantheon-greeter:
assignee: nobody → Kiran Hampal (khampal)
status: New → Confirmed
Daniel Fore (danrabbit) wrote :

Since we've moved to the clutter/GTK greeter I'm marking this as won't fix.

Changed in pantheon-greeter:
status: Confirmed → Invalid
status: Invalid → Won't Fix
Pim Vullers (pimvullers) wrote :

Is there an elementary specific project for this clutter/GTK greeter? Or is it just the basic one with the eGTK theme?

Daniel Fore (danrabbit) wrote :

Yes, it's this project :p

lp:pantheon-greeter

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers