Textarea does not have blinking cursor/visible focus

Bug #1014138 reported by Avi Romanoff
42
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Greeter
Fix Released
Low
Unassigned
elementary Stylesheet
Fix Released
Undecided
Unassigned

Bug Description

Call me insane, but it feels weird without it.

Changed in pantheon-greeter:
status: New → Confirmed
Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

I agree, it feels like you have to click it to type in it.

Changed in pantheon-greeter:
milestone: none → luna-beta1
importance: Undecided → Low
Revision history for this message
Daniel Fore (danrabbit) wrote :

I might be wrong, but I think I can fix at least the focus issue in eGTK. But I don't think I can do anything about the blinking cursor.

Revision history for this message
David Gomes (davidgomes) wrote :

It seems that this is a system-wide gtk option, so there's no reason it shouldn't be working, I looked it up on the code[1] and I found nothing relevant to fixing this bug.

[1] http://bazaar.launchpad.net/~elementary-pantheon/pantheon-greeter/1.x/view/head:/src/loginbox.vala

Revision history for this message
Daniel Fore (danrabbit) wrote :

So maybe it's possible this is some kind of system default not being set inside the greeter?

Revision history for this message
Tom Beckmann (tombeckmann) wrote :

I would have guessed on a theme problem. For two reasons: first, you can make the cursor appear by shifting focus around to the indicator menus, second, the selection color of the input field is messed up too.

Revision history for this message
David Gomes (davidgomes) wrote :

Tom, you mean that if you select an indicator and THEN get back to text area, the cursor shows up?

Revision history for this message
Daniel Fore (danrabbit) wrote :

The blue border should now appear in rev 534 of eGTK. Not sure if I can do anything about the blinking cursor though since it shows up in other content-view entries.

Changed in egtk:
status: New → Fix Committed
milestone: none → 3.2
Revision history for this message
Daniel Fore (danrabbit) wrote :

Cassidy I think it should be okay for beta with just the blue focus. But we'd like to see it fixed before Luna GM.

Changed in pantheon-greeter:
milestone: luna-beta1 → none
Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

Yeah I agree. Let's push this to beta 2 for the moment as the focus issue itself should be fixed.

Revision history for this message
Tom Beckmann (tombeckmann) wrote :

Sorry, it wasn't the theme's fault, just a focus issue.

Changed in pantheon-greeter:
status: Confirmed → Fix Committed
Daniel Fore (danrabbit)
Changed in egtk:
status: Fix Committed → Fix Released
Changed in pantheon-greeter:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers