make edit-able path bar use gtk.entry [$100]

Bug #996101 reported by Daniel Fore on 2012-05-07
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Medium
KJ Lawrence
elementary Stylesheet
Fix Released
Undecided
Daniel Fore

Bug Description

When the path bar is edit-able it should look like a text entry and not a depressed button.

Related branches

Victor Martinez (victored) wrote :

Actually, this should happen on the theme side if we want to keep the code in good shape. Marlin already had it like this in the past and I think it was changed because it felt hacky.

Daniel Fore (danrabbit) wrote :

Is there any way we can just change the class in the widget from button to entry when it becomes selected like that?

Mario Guerriero (mefrio-g) wrote :

we can add an hidden entry near the path bar and show it when the path is in the editing mode

xapantu (xapantu) wrote :

It was changed in marlin because it creates a lot of bugs with most themes (every theme but elementary IIRC). It is not hard to change, you have to add a gtkstylecontext and use it to draw the entry background, see libwidgets/LocationBar.vala.

Daniel Fore (danrabbit) wrote :

Ah, well if it creates problems in other themes can we just add a class like ".pathbar" or something and then I can do ".patbar:selected" in the theme or something.

David Gomes (davidgomes) wrote :

What is the progress on this bug? Daniel, any attempts on checking if it's an eGTK bug?

Cody Garver (codygarver) on 2012-09-16
Changed in pantheon-files:
assignee: nobody → elementary UX Team (elementary-design)
Daniel Fore (danrabbit) wrote :

David, I can't do anything on my side to force Files to use a class. Either a new class like ".pathbar" needs to be added so I can theme this class or Files needs to request the .entry class for the selected state (which a few people felt was hacky).

Mario Guerriero (mefrio-g) wrote :

Daniel creating a ".pathbar" class in the theme would be excellent. Let me to know when you will complete it and then I'll fix Files.

Daniel Fore (danrabbit) wrote :

Okay, this should be committed in eGTK. I did ".pathbar:active" since I only want to catch the active state of the button. It might need tweaking. But this should be fixed in eGTK.

Changed in egtk:
status: New → In Progress
Vincent (vincent-john-6) wrote :

Would adding a .pathbar class allow for adjusting the padding of the path-bar independently of the other toolbar items?

Daniel Fore (danrabbit) on 2012-10-20
Changed in pantheon-files:
milestone: luna-beta1 → luna-beta2
assignee: elementary UX Team (elementary-design) → nobody
Victor Martinez (victored) wrote :

Daniel, do we want pressed breadcrumbs to look like an entry too?

AFAIK ".pathbar:active" makes no distinction between the pressed editable area and every other area where there's an "active" state.

Daniel Fore (danrabbit) on 2012-12-23
Changed in pantheon-files:
milestone: luna-beta2 → luna-beta3
Daniel Fore (danrabbit) on 2014-03-18
Changed in pantheon-files:
milestone: isis-beta1 → none
Daniel Fore (danrabbit) wrote :

Committed a workaround in egtk.

I want to keep this bug open in Files since doing the CSS seems to have exposed that this widget is pretty hacky and probably needs to be redone at some point.

Changed in egtk:
status: In Progress → Fix Committed
milestone: none → isis-beta1
assignee: nobody → Daniel Fore (danrabbit)
Daniel Fore (danrabbit) on 2014-05-25
Changed in egtk:
status: Fix Committed → Fix Released
KJ Lawrence (kjtehprogrammer) wrote :

I think this is pretty much what my editable-pathbar branch does - convert the Gtk.EventBox pathbar widget into a Gtk.Entry widget. I'm still not 100% on how it works with other themes though - not really sure how to test that so it could still be a problem.

Changed in pantheon-files:
assignee: nobody → KJ Lawrence (kjtehprogrammer)

Renaming this ticket in light of the work that KJ has been doing.

summary: - make edit-able path bar look like text entry
+ make edit-able path bar use gtk.entry
Daniel Fore (danrabbit) wrote :
summary: - make edit-able path bar use gtk.entry
+ make edit-able path bar use gtk.entry [$100]
Daniel Fore (danrabbit) on 2014-06-17
Changed in pantheon-files:
status: Confirmed → Fix Committed
milestone: none → isis-beta1
xapantu (xapantu) wrote :

Hum, I am not sure this was a good move. Well, indeed, it probably solves a few bugs, but feature-wise, the integrated entry was better in my opinion.

It did not show /home/user, which is more user-friendly.
It was better readable, since the directories were clearly separated.
Still some graphical issue here (with adwaita, I'll try with elementary).
There was no glitch when you focused the entry.
And it looked best.

If I put it back (in an ideal world, without bugs), would it be merged, or will it be refused? (I am not that interested in writing a second time some useless code to be honnest ;) ).

Timo Reimerdes (timorei) wrote :

I don't think that the editable path bar was used by anyone who wouldn't know about /home/username/...

I actually thought this was a great move, as it makes entering the paths so much easier (including copy/paste from notes!)

Yes, the other version looked a bit smoother, but if you have to sacrifice copy-paste between console & filemanager for it to work, I'd stay with the pure text pathbar.

Daniel Fore (danrabbit) on 2014-12-29
Changed in pantheon-files:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers