restore from trash fails

Bug #1622053 reported by bruce on 2016-09-10
84
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Critical
Jeremy Wootten

Bug Description

I deleted some folders and files. When I go to the Trash folder, right click and select 'Restore from Trash' the window disappears, and the file or folder is not restored.

ProblemType: Bug
DistroRelease: elementary 0.4
Package: elementary-desktop 1.413+468~daily~ubuntu0.4.1 [origin: unknown]
ProcVersionSignature: Ubuntu 4.4.0-31.50-generic 4.4.13
Uname: Linux 4.4.0-31-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
CrashDB: elementary_meta
CurrentDesktop: Pantheon
Date: Fri Sep 9 17:25:11 2016
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: elementary-meta
SuspiciousXErrors:

ThirdParty: True
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

bruce (darkoverlordofdata) wrote :
J.Ar (j.ar) on 2016-09-10
affects: elementaryos → pantheon-files
J.Ar (j.ar) wrote :

deleted files are in /home/yourusername/.local/share/Trash/files/
or open Terminal and type... pantheon-files ~/.local/share/Trash/files/

bruce (darkoverlordofdata) wrote :

This doesn't address the issue I reported. I didn't ask where they were.

To repeat, it is pantheon-files that is broken, it crashes when I try to undelete. I am able to undelete just fine using nautilus.

bruce (darkoverlordofdata) wrote :

Perhaps this helps? This is what I get when I launch it from the command line, it gets a segment fault:

bruce@barsoom:~$ pantheon-files
[INFO 14:35:01.667607] Application.vala:155: Files version: 0.3.0.2
[INFO 14:35:01.667661] Application.vala:157: Kernel version: 4.4.0-36-generic
[INFO 14:35:01.734104] Application.vala:83: Report any issues/bugs you might find to http://bugs.launchpad.net/pantheon-files
Segmentation fault (core dumped)
bruce@barsoom:~$

Jeremy Wootten (jeremywootten) wrote :

Hello Bruce, thanks for the report. There was a regression recently in Files that was supposed to be fixed in version 0.3.0.2.

When you say you get a seg fault on the command line, is this immediately after launch or when you try to restore?

I am not having any trouble restoring from trash using version 0.3.0.2 rev 2310. Does it happen for all files or only those from certain locations or with certain names for example?

Changed in pantheon-files:
status: New → Confirmed
importance: Undecided → Critical
assignee: nobody → Jeremy Wootten (jeremywootten)
J.Ar (j.ar) wrote :

The version on loki stable with all updates is 0.3.0.2-0~r2304+pkg54~ubuntu0.4.1

The segfault only appears when you want to restore a file or folder.

For me all files and folders are affected from any location. So can't restore anything.

J.Ar (j.ar) wrote :

On a separate partition i have installed loki beta2 a few weeks ago.
I did a restart and checked if the problem is there too.
rev 2309 and after update rev 2310 has the same error.

Did not noticed the problem in the last weeks with beta2 because i don't delete or restore anything.

Jeremy Wootten (jeremywootten) wrote :

I managed to product a crash with a certain sequence of operations - but now I cannot reproduce it.

bruce (darkoverlordofdata) wrote :

This does not happen on launch, I see this immediately after selecting restore from right click.
I just tried creating several test files and folders in various locations and deleted them all.
Then I tried restoring them from pantheon-files. It crashed on all of them. Nautilus worked on all of them.

Jeremy Wootten (jeremywootten) wrote :

If you are able to compile and test this branch: lp:~jeremywootten/pantheon-files/fix-1622053-restore-from-trash-crash to see whether it fixes the problem I would be grateful. But make sure that there are no pantheon-files processes running in the background (e.g. by using gnome-system-monitor) and install the branch so that the trash plugin is overwritten (the plugins cannot run in the build directory). There is another bug I have just found where Files keeps running in the background even when you close the window in some cases which means the old version runs even though you think you are running a new version (unless you restart).

I did get a couple of crashes with the trunk and have re-written the part where the crash occurred, but now I cannot reproduce the crash in trunk - very odd.

J.Ar (j.ar) wrote :

I tried with the liveusb of loki (stable iso without any updates) on my other pc...same problem.

Create a simple file in home...delete...then go to trash and immediately after the click in the context menu 'restore from trash' pantheon-files closes(crash).

Jeremy Wootten (jeremywootten) wrote :

J.Ar: The version without updates 0.3.0 is known to have this regression - this update was supposed to have fixed it - clearly not for everyone.

J.Ar (j.ar) wrote :

Jeremy: The version in 'elementaryos-0.4-stable-amd64.20160909.iso' is 0.3.0.2 but i do not know the exactly revision. But it should just a hint, that the problem exists in the recent stable iso.

I would like to help with testing the revision 2311 but i do not know how to compile or install this branch.

J.Ar (j.ar) wrote :

Jeremy: I managed it! I installed many things like cmake and so on...and followed the INSTALL file and your email hint...and now i can restore files! Your fix works! Thx for your work and patience.

Zisu Andrei (matzipan) wrote :

Jeremy, wanna propose a merge?

Changed in pantheon-files:
status: Confirmed → In Progress
Jeremy Wootten (jeremywootten) wrote :

J.Ar: Thanks for succeeding in installing and testing that branch! I will propose it to be merged with trunk now.

Cody Garver (codygarver) on 2016-09-21
Changed in pantheon-files:
milestone: none → loki+1-beta1
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2016-10-10
Changed in pantheon-files:
milestone: juno-beta1 → 0.3.0.3
status: Fix Committed → Fix Released
賴家亨 (laichiaheng) wrote :

I still can't restore the files from trash.

賴家亨 (laichiaheng) wrote :

pantheon-files 0.3.0.3.1

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers