Shift+arrows selection doesn't work as expected in some cases

Bug #1563764 reported by Ash on 2016-03-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Files
Confirmed
Low
Jeremy Wootten

Bug Description

The implemented selection behavior has 2 issues (which seem to be related):

1. When the selection reaches the last item in a folder it begins to go further to the second selected item if "Shift + →" is pressed several times more. It should stop at the last item.

2. Undoing last item selection using "Shift + ←":

        1. Select several items ending at the last item of a folder using "Shift + →".
        2. Press "Shift + →" one more time(the selection doesn't change but this step is needed).
        3. Press "Shift + ←" to undo the selection of the last item.

An item before the first item in our selection adds to our selection. The behavior should have been undoing of the last item's selection.

Ash (ash1991) on 2016-03-30
Changed in pantheon-files:
assignee: nobody → Jeremy Wootten (jeremywootten)
Changed in pantheon-files:
status: New → Confirmed
importance: Undecided → High
Changed in pantheon-files:
status: Confirmed → In Progress
milestone: none → loki-beta1
Daniel Fore (danrabbit) on 2016-04-15
Changed in pantheon-files:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2016-08-15
Changed in pantheon-files:
status: Fix Committed → Fix Released
milestone: loki-beta1 → 0.3
Ash (ash1991) wrote :

The issue is still present for the opposite direction(if you choose some files ending in first item.)

Changed in pantheon-files:
status: Fix Released → Confirmed
Changed in pantheon-files:
milestone: 0.3 → juno-beta1
importance: High → Low
Jeremy Wootten (jeremywootten) wrote :

Confirmed for Icon View - List View seems OK. Icon View has some other unexpected behaviours which Shift-Arrow selection/deselecion as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers