State only saves on clean close

Bug #1454331 reported by Cassidy James Blaede on 2015-05-12
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Calculator
Fix Released
Low
Daniel Fore
Files
Confirmed
Low
Unassigned
Terminal
New
Low
Unassigned

Bug Description

The app's state is only saved when you explicitly/cleanly close it. If it terminates uncleanly (i.e. crashes, the computer dies, etc.), the state is not saved.

Possible solution: periodically save the state, perhaps after certain actions occur (i.e. after navigating to a folder, opening a tab, or toggling a UI state).

Daniel Fore (danrabbit) on 2015-05-12
Changed in pantheon-files:
milestone: none → loki-beta1
status: New → Confirmed
description: updated
Ash (ash1991) wrote :

The crash might be because of some open tabs so it's better to ask the next time user opens pantheon-files to restore the last session or the session before that.

Cody Garver (codygarver) on 2015-09-16
Changed in pantheon-files:
importance: Undecided → Medium
Cody Garver (codygarver) on 2016-02-12
Changed in pantheon-files:
importance: Medium → Low
Cody Garver (codygarver) on 2016-03-14
Changed in pantheon-files:
milestone: loki-beta1 → loki+1-beta1
Jeremy Wootten (jeremywootten) wrote :

Ideally Files should never crash! But you are right, because saving the tab state is more complex than binding a simple boolean such as "Show Hidden Files", it is only done on exit at the moment.

summary: - State only saves on explicit close
+ State only saves on clean close
description: updated

Calculator test case:
1. Open Calculator
2. Expand sidebar
3. Use xkill to kill the app
4. Re-open, see that the sidebar is not expanded

When closing the window normally, the sidebar saves its state.

Terminal test case:
1. Open Terminal
2. Navigate to a folder and open two extra tabs
3. Use xkill to kill the app
4. Reopen, see that the state was not saved

When closing the window normally, the location and tabs are saved.

Daniel Fore (danrabbit) wrote :

Cass, can you define more clearly what you mean by state for each instance? Like Jeremy said, some things (like dimensions) are a simple settings bind, but some things (like tabs) are more complicated

For Files and Terminal, I would expect it to remember the tabs that were open (i.e. if I had the Pictures, Downloads, and Documents folders each open in a tab, I'd think the app would re-open with those tabs still there). For Calculator, the sidebar state is the only thing I can think of off the top of my head.

Daniel Fore (danrabbit) on 2016-06-21
Changed in pantheon-calculator:
status: New → In Progress
assignee: nobody → Daniel Fore (danrabbit)
Changed in pantheon-calculator:
importance: Undecided → Low
milestone: none → loki-rc1
Cody Garver (codygarver) on 2016-06-21
Changed in pantheon-calculator:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) on 2016-07-10
Changed in pantheon-terminal:
milestone: none → loki+1-beta1
Cody Garver (codygarver) on 2016-08-10
Changed in pantheon-calculator:
milestone: none → loki-beta1
status: Fix Committed → Fix Released
Cody Garver (codygarver) on 2016-09-19
Changed in pantheon-terminal:
importance: Undecided → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers