pantheon-files-plugin-dropbox missing dependency

Bug #1355454 reported by Christoph K. on 2014-08-11
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Files
Invalid
Low
Unassigned
pantheon-files-plugin-dropbox (Ubuntu)
Undecided
Unassigned

Bug Description

just did a fresh install of freya beta1 and tried to start dropbox

pantheon-files tells me there's a dependency missing and dropbox does not start

[_LOG_LEVEL_INFO 23:17:33.726094] Application.vala:155: Files version: 0.2.0
[_LOG_LEVEL_INFO 23:17:33.726164] Application.vala:157: Kernel version: 3.13.0-32-generic
[_LOG_LEVEL_INFO 23:17:33.766811] Application.vala:83: Report any issues/bugs you might find to http://bugs.launchpad.net/pantheon-files
[_LOG_LEVEL_WARN 23:17:33.808365] PluginManager.vala:128: Failed to load module from path '/usr/lib/pantheon-files/plugins/libmarlin-dropbox.so': libmarlincore.so.0: cannot open shared object file: No such file or directory

ProblemType: Bug
DistroRelease: elementary OS 0.3
Package: pantheon-files 0.1.5.1+r1573+pkg34~ubuntu0.3.1 [origin: LP-PPA-elementary-os-daily]
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu3.3
Architecture: amd64
CrashDB: pantheon_files
CurrentDesktop: Pantheon
Date: Mon Aug 11 23:14:36 2014
EcryptfsInUse: Yes
GsettingsChanges:

SourcePackage: pantheon-files
UpgradeStatus: No upgrade log present (probably fresh install)

Dawid Deręgowski (venomen) wrote :

I have the same issue after upgrade. At my laptop with kernel 3.13.0-35-generic I manage to enable this plugin without errors but after some mixing it with marlin install/reinstall, maybe this should be some clue?

sudo ln -s /usr/lib/libpantheon-files-core.so.0 /usr/lib/libmarlincore.so.0
+ killing all instances of pantheon-files fixes this

that shared lib just got renamed i guess

Dawid Deręgowski (venomen) wrote :

Thx Christoph Keller, now it's working just fine :). Can you find solution also for the icons error (not showing up in \Dropbox\ folders)?

[_LOG_LEVEL_WARN 08:46:22.477086] Can't load icon emblem-ubuntuone-synchronized
[_LOG_LEVEL_WARN 08:46:22.477764] Can't load icon emblem-people
[_LOG_LEVEL_WARN 08:46:22.478533] Can't load icon emblem-ubuntuone-synchronized
[_LOG_LEVEL_WARN 08:46:22.479291] Can't load icon dropbox-unsyncable

Dawid Deręgowski (venomen) wrote :

Ok, I manage to repair it by myself.

Icons will work after cp from /home/yourlogin/.dropbox-dist/dropbox-lnx.x86_64-2.10.52/images/emblems/ to /usr/share/icons/elementary/emblems/24 and renaming it to: emblem-ubuntuone-synchronized.svg, emblem-ubuntuone-unsynchronized.svg, emblem-ubuntuone-updating.svg .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pantheon-files-plugin-dropbox (Ubuntu):
status: New → Confirmed
Changed in pantheon-files:
importance: Undecided → Medium
status: New → Confirmed
Jason Gambrel (jaygambrel) wrote :

In Freya it seems to look for these icons: emblem-ubuntuone-synchronized.svg, emblem-ubuntuone-unsynchronized.svg, emblem-ubuntuone-updating.svg in /usr/share/icons/hicolor/24x24/emblems. I didn't have these installed by default so had to grab them from various sites on the net. The icons for dropbox in /usr/share/nautilus-dropbox/emblems were not compatible as they were 64x64 png files instead of 24x24 svg files that seem to be required. I put the downloaded icons in /usr/share/icons/hicolor/24x24/emblems and they started working no problem.

- Jay

tags: added: dropbox
Jeremy Wootten (jeremywootten) wrote :

The dropbox plug-in is not currently being actively maintained (it is intended to use a new Cloud Providers API in future) and furthermore this bug relates to an old version of Files.
Please confirm this bug again if it is still relevant or occurs other than in association with that plug-in.

Changed in pantheon-files:
status: Confirmed → Incomplete
importance: Medium → Low
Changed in pantheon-files:
status: Incomplete → Invalid
Jeremy Wootten (jeremywootten) wrote :

There is an updated version of the dropbox-plugin for Loki at https://code.launchpad.net/~elementary-apps/pantheon-files/pantheon-files-plugin-dropbox but it needs testing. If there is a third-party plugin that works for you that is fine.

Ash (ash1991) wrote :

The elementary-dropbox project(https://github.com/zant95/elementary-dropbox) is working on loki but the purpose of the project isn't integrating dropbox to pantheon-files. It just integrates dropbox to wingpanel(makes dropbox appindicator show in wingpanel).

I have tested https://code.launchpad.net/~elementary-apps/pantheon-files/pantheon-files-plugin-dropbox and after some fixes to makeit compile it doesn't seem to work(neither emblems nor context menu items)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers