Use GtkHeaderBar

Bug #1254847 reported by Daniel Fore on 2013-11-25
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Undecided
Unassigned
Geary
Unknown
Unknown
Granite
Fix Released
Undecided
Corentin Noël
Maya
Fix Released
Medium
Corentin Noël
Noise
Fix Released
Undecided
Corentin Noël
Scratch
Fix Released
Medium
Mario Guerriero
Switchboard
Fix Released
Low
Corentin Noël
elementary-simple-scan
Undecided
Raphael Isemann

Bug Description

As soon as we have Gtk 3.10 available we want to take advantage of CSD and GtkHeaderBar. This bug is designed to aggregate and track our progress on implementing HeaderBar in our apps.

Related branches

Daniel Fore (danrabbit) on 2013-11-25
Changed in noise:
status: New → In Progress
Changed in switchboard:
status: New → In Progress
Daniel Fore (danrabbit) on 2013-11-25
Changed in noise:
assignee: nobody → Corentin Noël (tintou)
Changed in switchboard:
assignee: nobody → Corentin Noël (tintou)
Donte Greene (flykidd) wrote :

Midori already has a bug for this.

* https://bugs.launchpad.net/midori/+bug/1232558

Changed in scratch:
status: New → In Progress
assignee: nobody → Raphael Isemann (teemperor)
Changed in elementary-scan:
status: New → Confirmed
assignee: nobody → Raphael Isemann (teemperor)
Donte Greene (flykidd) on 2013-11-25
Changed in midori:
status: New → Confirmed
Phillip Sz (phillip-sz) on 2013-11-25
Changed in geary:
status: New → Confirmed
Changed in pantheon-files:
status: New → Confirmed
Changed in appcenter:
status: New → Confirmed
Raphael Isemann (teemperor) wrote :

The bug for geary is also reported here: https://bugzilla.gnome.org/show_bug.cgi?id=713587

Changed in midori:
status: Confirmed → Invalid
Changed in scratch:
importance: Undecided → Medium
milestone: none → 2.1
Changed in appcenter:
milestone: none → 0.2
assignee: nobody → Mario Guerriero (mefrio-g)
importance: Undecided → Medium
Changed in appcenter:
status: Confirmed → In Progress
Mario Guerriero (mefrio-g) wrote :

I just ported Scratch to GTk+ 3.10 but I am having some problems with replacing Gtk.ActionGroup items. If you know how to replace that deprecated elements, you are welcome.

Changed in scratch:
assignee: Raphael Isemann (teemperor) → Mario Guerriero (mefrio-g)
status: In Progress → Fix Released
no longer affects: midori
Daniel Fore (danrabbit) on 2013-12-09
Changed in geary:
importance: Undecided → Unknown
status: Confirmed → Unknown
Corentin Noël (tintou) on 2013-12-23
Changed in maya:
assignee: nobody → Corentin Noël (tintou)
status: New → In Progress
importance: Undecided → Medium
Auroral Xylon (avlabs314) wrote :

I was wondering whether Terminal could also use CSD? Since DynamicNotebook now supports dragging, maybe something like Google Chrome in Chrome OS could be implemented (see this screenshot: http://upload.wikimedia.org/wikipedia/commons/6/66/Chrome_OS_21.0.1172_Aura_Dev.png)? A class in the theme (.header-bar .dynamic-notebook etc.) could style it differently. I'm not sure whether this is possible or reasonable UX wise-though.

Corentin Noël (tintou) on 2014-01-06
Changed in switchboard:
importance: Undecided → Low
milestone: none → isis-beta1
status: In Progress → Fix Committed
Daniel Fore (danrabbit) wrote :

adding granite because of granite-demo

Changed in pantheon-files:
assignee: nobody → rosa maria (rprosamaria383)
Changed in granite:
assignee: nobody → rosa maria (rprosamaria383)
Corentin Noël (tintou) on 2014-01-30
Changed in maya:
status: In Progress → Fix Committed
milestone: none → isis-beta1
dobey (dobey) on 2014-03-28
Changed in pantheon-files:
assignee: rosa maria (rprosamaria383) → nobody
Changed in granite:
assignee: rosa maria (rprosamaria383) → nobody
Eric Karnes (karneseric) on 2014-04-19
Changed in switchboard:
status: Fix Committed → Fix Released
Changed in maya:
status: Fix Committed → Fix Released
Changed in pantheon-files:
status: Confirmed → Fix Released
Changed in noise:
status: In Progress → Fix Released
Daniel Fore (danrabbit) on 2014-11-22
Changed in granite:
status: New → Confirmed
Daniel Fore (danrabbit) on 2015-05-28
Changed in granite:
status: Confirmed → Fix Committed
assignee: nobody → Corentin Noël (tintou)
Daniel Fore (danrabbit) on 2015-06-08
Changed in granite:
milestone: none → freya-0.3.1
Daniel Fore (danrabbit) on 2015-06-30
no longer affects: appcenter
Cody Garver (codygarver) on 2015-08-30
Changed in granite:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.