Pantheon files crashes when copying file from network share.

Bug #1252928 reported by JaSauders on 2013-11-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Medium
Niclas Lockner

Bug Description

When copying a file from my server which hosts a samba network share, Pantheon files crashes. I am simply dragging and dropping the file in question from within the file browser window to a shortcut on the left nav of the Pantheon files window. Some relevant log entries below:

Nov 19 21:29:55 JS-E430 kernel: [31058.774057] pantheon-files[8844]: segfault at 7972746e45 ip 00007f038b876e0a sp 00007fffb54780b0 error 4 in libglib-2.0.so.0.3200.4[7f038b816000+f2000]
Nov 19 21:30:29 JS-E430 kernel: [31092.509753] pantheon-files[9907]: segfault at 13 ip 00007fe6524eaf4b sp 00007fff92dedc50 error 4 in libglib-2.0.so.0.3200.4[7fe6524a6000+f2000]
Nov 19 21:30:50 JS-E430 kernel: [31114.447708] pantheon-files[10260]: segfault at ffffffffffffffff ip 00007f7c06fb2fe0 sp 00007fffee5ccde0 error 5 in libgtk-3.so.0.400.2[7f7c06e1c000+47a000]
Nov 19 21:31:39 JS-E430 kernel: [31162.591826] pantheon-files[11273]: segfault at 900000018 ip 00007ffc9b9b0cfa sp 00007fffbbb9f730 error 4 in libgobject-2.0.so.0.3200.4[7ffc9b99c000+4d000]

Also, while on topic, it'd be nice to not have to edit the nautilus.desktop file in /usr/share/applications with it's OnlyShowIn=GNOME;Unity; entry that I had to comment out to make it visible. It gave me quite a run-around as I tried to get a workable file manager into elementary OS since Pantheon files wasn't able to handle this task.

Related branches

JaSauders (jasauders) wrote :

I pulled in Pantheon-Files from the daily PPA. That too crashed. At this point, literally 100% of the time I work with network shares (which is a substantial portion of my job) Pantheon-Files will crash. I wish I was kidding, but yes, 100% of the time it's crashing.

I couldn't find any hidden files/folders relating to Pantheon-Files in my home directory, so I just removed all of them and started over. Even still, Pantheon-Files crashes. It's literally unusable.

I ran pantheon-files from terminal and tried to open a picture on a Samba share. Same thing happened. Crash.

Here's the terminal output from that session:

http://paste.ubuntu.com/6705392/

JaSauders (jasauders) wrote :

At this point, only one of my systems is experiencing this issue. I'm finding that I cannot even open pictures from over a Samba network share without it crashing. It literally crashes 100% of the time on this unit when clicking to open an image file.

I removed Pantheon Files, purged it, and removed ~/.config/marlin in an effort to 'reset' it, then reinstalled Pantheon Files. Even then, same difference.

The latest Pantheon Files currently in the daily PPA made no difference either.

Here's a video depicting the consistent crashes I see. I have duplicated this exact behavior in two different environments using two different Samba file servers.

Are there any other locations where Pantheon Files configs might be stored so I can remove them in an effort to fully reset Pantheon Files? I just can't seem to find a connection as to why it happens on this system but not any others, despite the fact they were all installed from the same ISO/flash drive right around the same time.

https://www.dropbox.com/s/723z2trb8qy0key/pantheon-files-crash.mp4

Niclas Lockner (niclasl) wrote :
Niclas Lockner (niclasl) on 2014-01-11
Changed in pantheon-files:
assignee: nobody → Niclas Lockner (niclasl)
Niclas Lockner (niclasl) on 2014-01-11
Changed in pantheon-files:
status: New → In Progress
David Gomes (davidgomes) on 2014-01-14
Changed in pantheon-files:
status: In Progress → Fix Committed
importance: Undecided → High
importance: High → Medium
Cody Garver (codygarver) on 2014-01-14
Changed in pantheon-files:
milestone: none → isis-beta1
Cody Garver (codygarver) on 2014-02-09
Changed in pantheon-files:
milestone: isis-beta1 → 0.1.6
status: Fix Committed → Fix Released
David Pastl (pastl) wrote :

I'm still seeing this issue. Running a fully updated version of elementary os as of this posting.

Renaming files also causes it to crash, it's pretty much unusable on SAMBA shares.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments