Pantheon files cause high hdd and cpu usage when window moving

Bug #1243657 reported by Jacob S. on 2013-10-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Files
Fix Released
Medium
Jacob S.

Bug Description

Each time when I move pantheon-files window it causes hdd crunch sound and high cpu usage in 2-5 seconds. When I click a "close" button in this period, window is not closing.
As far as I know pantheon files is a fork of nautilus, so when I tried nautilus, there is no such problem.

My system is:
Phenom II x4 B35 Processor (unlocked Athlon II x3)
Seagate ST3750528AS (750Gb)

elementary OS luna with all fresh updates at this time;
kernel: linux-generic-lts-raring;
no proprietary drivers installed.

Please specify what other information I can post to confirm this bug.

Added:
The 'top' utility shows that dconf-service is going crazy, not pantheon-files process itself. But bug is still there, when I use pantheon-files.

After some investigation I've found that if I run command "killall -SIGSTOP dconf-service", the problem is gone, but after that I can't close pantheon windows, like pantheon-terminal, pantheon-files and so on.

Related branches

Jacob S. (jacob1237) on 2013-10-23
description: updated
description: updated
description: updated
description: updated
Jacob S. (jacob1237) on 2013-10-24
description: updated
Jacob S. (jacob1237) on 2013-10-24
description: updated
Jacob S. (jacob1237) on 2013-10-24
Changed in elementaryos:
status: New → In Progress
assignee: nobody → Jacob (jacob-100205)
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2013-10-24
Changed in elementaryos:
status: Fix Committed → In Progress
milestone: none → isis-beta1
Cody Garver (codygarver) on 2013-10-31
Changed in elementaryos:
importance: Undecided → Medium
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2013-11-11
affects: elementaryos → pantheon-files
Changed in pantheon-files:
milestone: isis-beta1 → none
milestone: none → 0.1.6
Cody Garver (codygarver) on 2013-11-11
Changed in pantheon-files:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers