Pressing ctrl key crashes pantheon-files

Bug #1216803 reported by Maxime Gauduin on 2013-08-26
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
High
Unassigned

Bug Description

This is happening with 0.1.3 and bzr version. Running on Arch Linux and built with vala0.16. Holding the Ctrl key makes pantheon-files crash instantly.

Terminal output:

[_LOG_LEVEL_INFO 10:07:37.489645] Application.vala:77: Files version: 0.1.3
[_LOG_LEVEL_INFO 10:07:37.489860] Application.vala:79: Kernel version: 3.10.7-1-ARCH
[_LOG_LEVEL_INFO 10:07:37.558747] Application.vala:61: Report any issues/bugs you might find to http://bugs.launchpad.net/pantheon-files
[_LOG_LEVEL_WARN 10:07:37.565483] [libnotify] Failed to connect to proxy
[_LOG_LEVEL_INFO 10:07:37.572312] PluginManager.vala:137: Loading plugin for /usr/lib/pantheon-files/plugins/core/libmarlin-contractor.so
[_LOG_LEVEL_INFO 10:07:37.574127] PluginManager.vala:137: Loading plugin for /usr/lib/pantheon-files/plugins/core/libmarlintrash.so
[_LOG_LEVEL_INFO 10:07:37.584494] PluginManager.vala:137: Loading plugin for /usr/lib/pantheon-files/plugins/core/libmarlinctags.so
[_LOG_LEVEL_INFO 10:07:37.588992] PluginManager.vala:137: Loading plugin for /usr/lib/pantheon-files/plugins/core/libnetwork-places.so
[_LOG_LEVEL_INFO 10:07:38.068756] plugin.vala:121: CANCEL
[_LOG_LEVEL_WARN 10:07:38.068924] plugin.vala:136: CTags Plugin dir file:///home/alucryd
[_LOG_LEVEL_INFO 10:07:38.076550] slot_active file:///home/alucryd
[_LOG_LEVEL_INFO 10:07:38.076675] slot_active > merge menus
[_LOG_LEVEL_INFO 10:07:38.127524] gof-callwhenready.vala:83: call when ready OK - empty list
[_LOG_LEVEL_WARN 10:07:38.169702] ViewContainer.vala:181: directory done loading
[1] 3693 segmentation fault (core dumped) pantheon-files

Julián Unrrein (junrrein) wrote :

Thanks for reporting!

Does pressing a keyboard shortcut (such as Control+H for showing hidden files) also makes Files crash?

What is your GTK version? Any other details about your system would be helpful.

Maxime Gauduin (alucryd) wrote :

Thx for the quick reply. I should have said pressing instead of holding down, sorry about that, I'll modify the title. Pressing Ctrl crashes the program, I don't have time to press another key to try a combination.

I have included a gdb log, should have done that from the start. gdb seems to point out a problem with libgobject. I can also provide a strace, the file weighs 11MB though.

Our gtk3 is at 3.8.2, granite is 0.2.2, glib2 is 2.36.4, the gtk3 theme is egtk (bzr 4.x branch), theme seems to be irrelevant though, changing it has no effect. I'm running an HD5870M with oss radeon drivers (catalyst had the same effect) and my cpu is a first gen i7, but that shouldn't matter.

summary: - Holding down Ctrl crashes pantheon-files (segfault)
+ Pressing Ctrl crashes pantheon-files (segfault)

I tried Shit-suppressing today which made files crash too. I decided to try other things, turns out pressing any key at all crashes files, be it a special key or just a letter, all with the same error.

summary: - Pressing Ctrl crashes pantheon-files (segfault)
+ Pressing a key crashes pantheon-files (segfault)

Thanks for the replies! The info is definitely useful.

The most interesting thing for us is the gdb log, and I'm afraid it is quite incomplete. There is no backtrace provided, which is the main reason of using gdb in these cases. To get a stack trace under gdb, run Files until it crashes and then run (in the gdb console) 'thread apply all bt full'.

For this command to give useful info, you will need to have debug symbols installed for all the involved libraries. I think that in Arch, debug symbols are provided as *-debug packages (e.g. libglib2-debug). You will need to install debug symbols for glib2, gio2, gtk3, granite and pantheon-files.

If you compiled Files from source, you must tell CMake to generate debug symbols explicitely. To do so, follow the build instructions detailed in the HACKING file.

A strace could be useful too, I would tell you to attach here as you already took the hassle of getting it.

Maxime Gauduin (alucryd) wrote :

Sorry about the late reply.

We don't have debug packages in Arch Linux, by default every debug symbol is stripped from our packages (except glibc). I've rebuilt the needed libraries without stripping, but I'm still seeing a lot of "No symbol table available" though I don't really know what that means.

In any case, please find enclosed the gbd report with 'thread apply all bt full' as well a new strace (much smaller in size). Hope the gdb backtrace is correct.

Maxime Gauduin (alucryd) wrote :

And the strace.

Julián Unrrein (junrrein) wrote :

Hi again Maxime,

The "No symbol table info available" means that gdb couldn't find debug symbols for that function. It seems that you are either lacking debug symbols for both glib and gtk, or that gdb just can't find them. If it isn't the first one, I don't know how to solve the second one.

For the record, as this is a keyboard-related issue, were you running ibus?

Maxime Gauduin (alucryd) wrote :

Hi Julián,

This is weird, I'm positive I disabled the symbol stripping before rebuilding those libs (and package sizes was larger than with stripping). Even assuming I did it wrong, it should at least detect the symbols from the libs in the glibc precompiled package, but it does not. Those in pantheon-files are correctly detected, one good thing at least. I will look into it and report back here.

As for ibus, it is indeed running, but killing it has no effect, files still crashes. I've had some rare occurences of files not crashing, but can't pinpoint a reason why, it seems to be random. Also, one Arch user reported he was not affected by this bug whatsoever.

Cody Garver (codygarver) wrote :

This is 99% reproducible on Saucy

Julián Unrrein (junrrein) wrote :

Hey another question, does this happen in Icon, List or Columns view? Or in all of them?

Julián Unrrein (junrrein) wrote :

@Cody

You will have to check the backtrace for your crashes. It may be a separate issue.

Cody Garver (codygarver) on 2013-09-17
Changed in pantheon-files:
milestone: none → isis-beta1
importance: Undecided → High
status: New → Confirmed
Maxime Gauduin (alucryd) wrote :

Hi guys,

Sorry about my lack of reply. The last week has been kinda hectic, and what few experiments I did to have those symbols working failed.

I've noticed a pattern in the crashes though, it won't crash the first time I launch files and press some keys, only subsequent times. Switching to another view and back to icon view makes it possible to press keys again, but only in the current instance: close and launch files again and the crashes are back. List and column views do not crash btw. Afaict, those behaviors are 100% reproducible here.

Hope this is of any help, and sorry about the bactrace, I'm at a loss as to why the symbols are not detected even when they're present.

Julián Unrrein (junrrein) wrote :

Hi Maxime,

Don't worry about it, you helped us a lot! Now the crash is narrowed to the icon view.

This will take some time to get fixed though, since this seems that this crash happens to people with newer libraries, and I'm not updating for a while.

Cheers

Maxime Gauduin (alucryd) wrote :

Hi Julián,

I understand, I can live with it for the time being. Thx for your work!

Cheers

Cody Garver (codygarver) on 2013-09-27
summary: - Pressing a key crashes pantheon-files (segfault)
+ Pressing ctrl key crashes pantheon-files
Trustmaster (trustmaster) wrote :

I confirm this on Saucy, strace is attached. It crashes when pressing any key.

Alex Lourie (alourie) wrote :

@CodyGarver - Doesn't seem to happen on ISIS (apr 5)

Avi Romanoff (aroman) wrote :

Can't reproduce on Isis, so I'm unsetting the beta1 milestone to reflect this.

Changed in pantheon-files:
milestone: isis-beta1 → none
Trustmaster (trustmaster) wrote :

Seems like Isis uses libraries different from Ubuntu/Saucy, that's why this bug can't be reproduced on Isis while it is still present on Ubuntu.

Maxime Gauduin (alucryd) wrote :

Confirmed working correctly on Arch Linux as well, thx guys!

Trustmaster (trustmaster) wrote :

Updating libglib from 2.38 to 2.40 fixed it on Ubuntu Saucy for me.

Cody Garver (codygarver) wrote :

Pretty sure this is fixed

Changed in pantheon-files:
milestone: none → freya-beta1
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) on 2014-12-29
Changed in pantheon-files:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers