Installing a plugin does not activate it

Bug #1121017 reported by Sergey "Shnatsel" Davidoff on 2013-02-10
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Medium
Victor Martinez

Bug Description

Installing a plugin does not activate it. If the user installs a plugin, they still have to activate it via an area of Preferences menu that wasn't there previously. This is very confusing.

The plugin whitelist in dconf (org.pantheon.files.Settings plugins-enabled) should be converted to a blacklist, so that new plugins are activated automatically.

ProblemType: Bug
DistroRelease: elementary OS 0.2
Package: pantheon-files 0.1-0~r1098+pkg10~precise1
ProcVersionSignature: Ubuntu 3.5.0-19.30~precise1-generic 3.5.7
Uname: Linux 3.5.0-19-generic x86_64
ApportVersion: 2.0.1-0ubuntu17.1+elementary3~precise1
Architecture: amd64
CrashDB: pantheon_files
Date: Sun Feb 10 13:38:13 2013
GsettingsChanges:

InstallationMedia: elementary OS 0.2 "Luna" - Build amd64 LIVE Binary 20121001-15:16
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=ru_RU.UTF-8
 SHELL=/bin/bash
SourcePackage: pantheon-files
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Moved point (2) to a separate bug 1121033

description: updated
Cody Garver (codygarver) on 2013-02-10
Changed in pantheon-files:
milestone: none → luna-beta3
importance: Undecided → Medium
Cody Garver (codygarver) on 2013-02-12
Changed in pantheon-files:
status: New → Confirmed
Changed in pantheon-files:
status: Confirmed → Triaged
Cody Garver (codygarver) on 2013-05-13
Changed in pantheon-files:
status: Triaged → In Progress
assignee: nobody → Victor (victored)
milestone: luna-beta3 → luna-rc1
Cody Garver (codygarver) on 2013-05-13
Changed in pantheon-files:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers