Stylize status overlay

Bug #1073431 reported by Daniel Fore on 2012-10-31
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Wishlist
Victor Martinez
elementary Stylesheet
Fix Released
Wishlist
Daniel Fore

Bug Description

The little status overlay thingy (That shows file type and size) should be stylized a little sexier than it currently is.

Attached a mockup of some bit of transparency cleverness.

Daniel Fore (danrabbit) wrote :
Changed in pantheon-files:
importance: Undecided → Wishlist
Daniel Fore (danrabbit) wrote :

Files devs, does this element currently have a theme-able class? If not, can we create one?

Changed in egtk:
importance: Undecided → Wishlist
Victor Martinez (victored) wrote :

The name of the widget is "MarlinViewOverlayBar". The problem is that it has a built-in CSS stylesheet that is not overridable from the user's theme. I will lower the priority of that stylesheet and mark this bug as fixed for pantheon-files.

Changed in pantheon-files:
status: New → Confirmed
Changed in egtk:
status: New → Confirmed
Victor Martinez (victored) wrote :

Daniel, it's all yours now. Please use the "files-overlay-bar" style class.

Changed in pantheon-files:
status: Confirmed → Fix Committed
assignee: nobody → Victor Eduardo (victored)
milestone: none → 0.2
Daniel Fore (danrabbit) wrote :

Okay, so I ran into so problems. It looks like status overlay doesn't accept padding, but also border-radius and transparency don't work. There is some kind of background behind this widget.

Changed in pantheon-files:
status: Fix Committed → In Progress
Victor Martinez (victored) wrote :

Daniel, all the problems you've mentioned are fixed now.

Changed in pantheon-files:
status: In Progress → Fix Committed
Daniel Fore (danrabbit) wrote :

Okay Victor, a couple more things xD

1. In the attached screenshot you can see that there are little gray corners here for some reason.

2. Is there a way to add padding around the outside of this box so it's not directly up against the side of the window?

Daniel Fore (danrabbit) on 2012-11-04
Changed in pantheon-files:
status: Fix Committed → In Progress
Ikey Doherty (ikey-doherty) wrote :

You need to set the EventBox's child window to be invisible (the one recieving events)
http://www.valadoc.org/#!api=gtk+-3.0/Gtk.EventBox.set_visible_window

i.e. yourEventBox.set_visible_window (false)
You want to avoid any dependency on GTK drawing via extension methods, instead rely
solely on a cairo drawing function (using the draw event, cairo's expose)

This should correct the issue for you (Also ensure to pad the rectangle clipping 1 or 2px)

Victor Martinez (victored) wrote :

Ikey, thanks for the suggestion! I forgot to set that property to false. Drawing directly with Cairo is not recommended in this case though, because we want full theming support, and the family of gtk_render_*() is there to give us that for free.

Victor Martinez (victored) wrote :

Daniel,

> 1. In the attached screenshot you can see that there are little gray corners here for some reason.
Yeah, I forgot to do what Ikey suggested above.

> 2. Is there a way to add padding around the outside of this box so it's not directly up against the side of the window?
Yes, it is :) Although we're no longer talking about padding here, but the "margin" style property. The correct order is margin/border-width/padding, where padding refers to internal spacing. Margin support is still not implemented, but I'll add it as soon as possible.

Victor Martinez (victored) wrote :

Again, all fixed. Please mark the bug as "fix committed" if everything works as you expect.

Ikey Doherty (ikey-doherty) wrote :

Glad I could be of assistance (And quite happy to see that GTK3 is now much more willing to listen than it previously
was :))

Daniel Fore (danrabbit) wrote :

Looking sexy, marking both as fixed. Thanks Victor (and Ikey!)

Changed in egtk:
status: Confirmed → Fix Committed
Changed in pantheon-files:
status: In Progress → Fix Committed
Changed in egtk:
milestone: none → 3.3
assignee: nobody → Daniel Fore (danrabbit)
Changed in egtk:
status: Fix Committed → Fix Released
Daniel Fore (danrabbit) on 2013-02-14
Changed in pantheon-files:
milestone: 0.2 → luna-beta2
Cody Garver (codygarver) on 2013-04-15
Changed in pantheon-files:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers