Icon size changes viewing icons folder

Reported by Corentin Noël on 2012-06-19
154
This bug affects 32 people
Affects Status Importance Assigned to Milestone
Files
Medium
Julián Unrrein

Bug Description

When I browse the /usr/share/icons/ folder and enters into a folder, Files keeps the icon's size in memory and use it as default size for other folders

Related branches

Marijo Mustac (mustacmarijo) wrote :

Just a short screencast to show the problem. I've wanted to report this bug, but when I sw it was already reported.

summary: - Don't remember images size
+ Icon size changes viewing icons folder
Changed in pantheon-files:
status: New → Confirmed

I made a screencast of a bug

Cameron Norman (cameronnemo) wrote :

I looked into this a little further and it only changes the size if it is an .svg icon. I am going to see the behaviour for any square svg.

Cameron Norman (cameronnemo) wrote :

Sorry, my last statement was wrong, this behaviour has occurred with Faenza pngs as well. It works for some icons, but not others. Faenza, elementary, humanity, tango, oxygen, and ubuntu-icon-theme all cause this, while the GNOME icons and a fresh icon I drew up do not exhibit this behaviour. This behaviour also only occurs in the ~/.icons or /usr/share/icons folder.

UPDATE: More playing around with a fresh icon I made brought some even more interesting results. When my icon was in a folder called 16, the icons changed to 16 (my icon was 16 pixels). When my icon was in a folder called 64 (same 16 pixel icon), the icons changed to size 64. If a folder is named after an irregular number, say 101, the icons seem to change to the closest regular number (128). The icons in the folder *do* need to be square for this to happen.

My hypothesis is that somebody attempted to implement a feature that would show icons in their native sizes (like nautilus does), but didn't implement the feature effectively (or intelligently in my opinion). By simply axing this feature (I am assuming my hypothesis is correct here), we can solve this bug.

Cameron Norman (cameronnemo) wrote :

TL;DR :

Pantheon-files tries to open icon folders and display the icons in their native size (16, 24, 48, 64, etc), but when it leaves the folder, the size persists for all icons.

This seems to be an attempted feature because it only happens in /usr/share/icons and ~/.icons. Also, the folder must be a number (52, 48, 101, it doesn't haver to be the exact size) and the icons inside must be square.

If this is a feature mal-implemented, we can axe the feature and avoid this bug and the only negative is that icons are blurry if they don't match pantheon-files's icon size.

***If we want this feature, it should really be implemented a different way. In its current incarnation, it depends on locations of icons and the containing folders to identify the icon size. This is an indirect and inefficient way of identifying the icon size. If pantheon can simply recognize what size a square image is, then we can make an exception for that situation. I think Nautilus accomplishes the task this way, so we could look to their code for an idea on how to implement it.

Cody Garver (codygarver) on 2013-04-18
Changed in pantheon-files:
importance: Undecided → High
milestone: none → luna-beta3
tags: added: reproducible
Cody Garver (codygarver) on 2013-05-13
Changed in pantheon-files:
importance: High → Medium
kjg (kjgwork) wrote :

what is the proceedure to set the folder icons back to default. They are HUGE!. Thanks!

kjg (kjgwork) wrote :

Nevermind. I watched the screencast and fixed it myself. Thanks!

Changed in pantheon-files:
assignee: nobody → Julián Unrrein (junrrein)
Changed in pantheon-files:
status: Confirmed → In Progress
Cody Garver (codygarver) on 2013-06-27
Changed in pantheon-files:
milestone: 0.3-beta1 → 0.1.2
Cody Garver (codygarver) on 2013-06-27
Changed in pantheon-files:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers