should show image dimensions in Properties

Bug #1011176 reported by David Raid on 2012-06-10
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Files
Fix Released
Wishlist
Christophe Bastin

Bug Description

One of the things I loved about Nautilus's properties window (well, the only thing) was that when looking at the properties of an image or video, it showed you the dimensions of the video.

This was very useful, it allowed me to quickly check if a picture would fit perfectly as a wallpaper or, for videos, if something was of HD dimensions, how well an exported video would fit on another device's screen, etc etc.

In short, it was a useful bit of information and a property of a file I think should really be in the properties window of a file. It saves having to open the file itself to check and thus saves time, as a properties window should.

Perhaps other media properties could be in the info pane of the properties window, like the birate or codec. That would be useful for audio files. I suppose this bug is more regarding extended media information in the properties window, but I felt the summary should refer to my main want. :]

--Edit

I've also noticed some concern about the duplication of information in the info pane and the properties window. I feel the properties window should be just for more detailed information like this, as in the spirit of getting back to basics, the info pane should be basic info, the properties window should be the properties of the file, giving file type targeted information.

Related branches

David Raid (davidraid) on 2012-06-10
description: updated
Daniel Fore (danrabbit) on 2012-06-11
summary: - [Opinion] Properties window should show image/video dimensions
+ should show image/video dimensions in Properties
Changed in pantheon-files:
status: New → Confirmed
importance: Undecided → Wishlist

Hi,

I made some code to show image dimensions in the property window. However, the way to get informations from videos is totally different.
Shouldn't we fill a different bug report for video dimensions ?

Yeah that's fine

On Sun, Nov 24, 2013 at 10:11 AM, Christophe Bastin <
<email address hidden>> wrote:

> Hi,
>
> I made some code to show image dimensions in the property window. However,
> the way to get informations from videos is totally different.
> Shouldn't we fill a different bug report for video dimensions ?
>
> --
> You received this bug notification because you are subscribed to
> elementary.
> https://bugs.launchpad.net/bugs/1011176
>
> Title:
> should show image/video dimensions in Properties
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/pantheon-files/+bug/1011176/+subscriptions
>

--
Cody Garver

summary: - should show image/video dimensions in Properties
+ should show image dimensions in Properties
Changed in pantheon-files:
assignee: nobody → Christophe Bastin (ozzmos)
Changed in pantheon-files:
status: Confirmed → In Progress
Cody Garver (codygarver) on 2013-11-27
Changed in pantheon-files:
milestone: none → isis-beta1
Cody Garver (codygarver) on 2013-12-16
Changed in pantheon-files:
status: In Progress → Fix Committed
Cody Garver (codygarver) on 2014-02-09
Changed in pantheon-files:
milestone: isis-beta1 → 0.1.6
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers