Better distinguish between hide modes

Bug #1290340 reported by Pablo R. Dinella
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Pantheon Dock
Invalid
Undecided
Unassigned
Switchboard Desktop Plug
Fix Released
Low
Djax

Bug Description

I can't figure out what's the difference between the two if do not go and try each one. That should be simpler to choose and predict what will happen to the dock with the selected option...

Related branches

Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

I think rather than using a combobox with the names that the Plank devs chose, we could use radio buttons with a brief description of the behavior.

Here's a quick mockup of that (attached).

Changed in pantheon-dock:
status: New → Invalid
Changed in switchboard-plug-pantheon-shell:
status: New → Confirmed
importance: Undecided → Low
Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

Actually those first two hide modes should be swapped since we ship with the first one enabled, and it makes sense to have the first be the default. Attached is a fixed mockup.

I'm also still not 100% sold on the phrasing, but here's what I have in text form:

- Hide on maximize
+ Hide when focused window is maximized

- Intelligent hide
+ Hide when focused window overlaps the dock

- Auto hide
+ Automatically hide when not being used

- Don't hide
+ Never hide

summary: - Auto hide vs Intelligent Hide
+ Better distinguish between hide modes
Revision history for this message
Danielle Foré (danrabbit) wrote :

I agree with expanding the hide modes into radios. That definitely makes it easier to compare and takes advantage of all the space we have available.

I'm unsure the scale is a good choice unless we make hard stops at Small, Medium, Large, XL. Maybe it would be better if we actually showed dummy icons here instead?

I'm personally not a massive fan of exposing the dock theme. I feel like our theme is part of our brand and I don't want it to be easy to change. I don't want see YouTube videos that say "elementary OS" unless it actually looks like it. It's bad/confusing advertising. Especially when people are using Mac-like themes.

Revision history for this message
Cassidy James Blaede (cassidyjames) wrote :

Dan, that all makes sense. I'd say file some bugs for your other UI changes and we can discuss them further there. 😉

Changed in switchboard-plug-pantheon-shell:
status: Confirmed → In Progress
assignee: nobody → Djax (parnold-x)
Cody Garver (codygarver)
Changed in switchboard-plug-pantheon-shell:
milestone: none → freya-beta2
status: In Progress → Fix Committed
Changed in switchboard-plug-pantheon-shell:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers