Use ESC key for clearing result

Bug #1414722 reported by mporten on 2015-01-26
26
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Calculator
Fix Released
Wishlist
Unassigned

Bug Description

What it says in the summary. Let me use ESC key to reset, as "C" button does.

Related branches

Marvin Beckers (embik) on 2015-01-26
Changed in pantheon-calculator:
importance: Undecided → Wishlist
Changed in pantheon-calculator:
status: New → Confirmed
Sam (sam-tabascoterrier) wrote :

I just came here to log this too. I find it mildly frustrating having to switch from keypad to mouse to clear the calculator (or to hold down the backspace for an extended period of time).

Escape to clear seems to be the convention in most other calculator applications, and it's absence is an annoyance to me, so I believe it should be the convention in Pantheon Calculator also.

I've posted a bounty to encourage the change:
https://www.bountysource.com/issues/8208792-use-esc-key-for-clearing-result

xapantu (xapantu) on 2015-08-20
Changed in pantheon-calculator:
status: Confirmed → Fix Committed
Daniel Fore (danrabbit) on 2015-09-18
Changed in pantheon-calculator:
milestone: none → loki-beta1
Daniel Fore (danrabbit) on 2015-10-22
Changed in pantheon-calculator:
milestone: loki-beta1 → loki-alpha1
Cody Garver (codygarver) on 2016-07-21
Changed in pantheon-calculator:
milestone: loki-alpha1 → loki-beta1
Cody Garver (codygarver) on 2016-08-10
Changed in pantheon-calculator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers