Adding a new CP to an existing line crashes

Bug #1292735 reported by Frederic Da Vitoria on 2014-03-14
This bug report is a duplicate of:  Bug #1016258: libpano hangs with Panini projection. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Panotools
Undecided
Unassigned

Bug Description

Hugin 2014.0.0.6951a0bde18c built by Matthew Petroff on Windows 7 64 bits & Intel HD Graphics 4000

7 images panorama with 2 lenses, adding a new line to the single lens 1 image. Adding the first CP pair goes OK. But when I add a second CP pair on that line, Hugin enters an endless loop when I press the "Add" button. Hugin uses completely one of my 4 cores and after more that 15 minutes waiting, I decided that the only solution was aborting. First time this happened in the middle of my work. I had a previous backup so I started again and it hung again. I loaded again the project, added the first CP pair for line 3, backed up, exited Hugin, reloaded, added the second CP pair, and got stuck again.

To reproduce the bug: open the project, go to the last image and try to add a new CP pair to Line 3

tmodes (tmodes) wrote :

This is the same bug as you already reported.

affects: hugin → panotools
Frederic Da Vitoria (davitofrg) wrote :

You are right (although this bug did not look the same at first sight): changing the projection to equirectangular allowed me to add my second CP pair.

Frederic Da Vitoria (davitofrg) wrote :

Other info maybe relevant: I added my CP pair, optimized, went into preview, changed the projection to Panini, saw that I had forgotten to optimize photometrics, did so and hanged Hugin when pressing the OK button in the the photometrics dialog .

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers