panflute causes dbus-daemon to eat 90-100% CPU when clicking on it to open a non available player

Bug #718169 reported by Pacho Ramos on 2011-02-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Panflute
Undecided
Unassigned
Gentoo Linux
Fix Released
Medium

Bug Description

As reported downstream in:
http://bugs.gentoo.org/show_bug.cgi?id=354729

When I click on panel applet to open banshee or rhythmbox, dbus-daemon starts
to consume a lot of CPU and nothing is opened. I have looked at
~/.xsession-errors but nothing is shown there :-(

After some minutes dbus-daemon stops to consume CPU, I think that it's because
of command not being found on my system (I don't have rhythmbox installed and
banshee is called "banshee-1" on Gentoo)

This is a regression over old music-applet

When I click on panel applet to open banshee or rhythmbox, dbus-daemon starts to consume a lot of CPU and nothing is opened. I have looked at ~/.xsession-errors but nothing is shown there :-(

Also tried to bump to 0.7.0 version with the same problem

After some minutes dbus-daemon stops to consume CPU, I think that it's because of command not being found on my system (I don't have rhythmbox installed and banshee is called "banshee-1" on Gentoo)

Reproducible: Always

Changed in gentoo:
importance: Unknown → Medium
status: Unknown → Confirmed

Not sure if this regression should block music-applet removal :-/

+*panflute-0.7.0 (15 Apr 2011)
+
+ 15 Apr 2011; Pacho Ramos <email address hidden> +panflute-0.7.0.ebuild:
+ Version bump with lots of bugfixes (bug #363701 by Justin Lecher), also
+ fixing old dbus-daemon cpu usage bug #354729 and modifying RDEPEND as it's
+ depending automagically on gnome stuff causing problems like bug #362589 (by
+ Diego Elio Pettenò).
+

Changed in gentoo:
status: Confirmed → Fix Released
Pacho Ramos (pacho) on 2011-04-17
Changed in panflute:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.