Panflute no longer displays album art from Banshee

Bug #618190 reported by Wage on 2010-08-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Panflute
Medium
Paul Kuliniewicz

Bug Description

panflue no longer displays album art in notification bubble

Related branches

Paul Kuliniewicz (kuliniew) wrote :

What version of Panflute? What player? What version of that player? Does it work initially and then stops working at some point, or does it never work at all? What is in the log files under ~/.local/share/panflute/ ?

Changed in panflute:
status: New → Incomplete
Wage (wage) wrote :

Panflue Version: 0.6.2
Banshee Version: 1.6.1

The popup notifications that panflute displays don't include any album art and haven't since it became panflute.

There was 6 lines in the log file similar to this one:

WARNING [panflute.applet.player.ArtLoaderThread] Loading file:///home/justin/.cache/album-art/album-e4add8737968b7c1c94ad82f2306de25.jpg failed: [Errno 2] No such file or directory: '/home/justin/.cache/album-art/album-e4add8737968b7c1c94ad82f2306de25.jpg'

I deleted the log file and ran banshee some more but nothing else ever got added.

Banshee is set to write the metadata to the files, could that be why?

Wage (wage) wrote :

Forgot to add, I have no album-art folder in that location.

Paul Kuliniewicz (kuliniew) wrote :

Banshee appears to have switched to ~/.cache/media-art/ instead of ~/.cache/album-art/ at some point since I wrote the album art loading code. Lovely.

Until this gets fixed, a workaround would be to add a symlink from album-art to media-art, so that Panflute's lookups will work.

Changed in panflute:
status: Incomplete → Confirmed
assignee: nobody → Paul Kuliniewicz (kuliniew)
importance: Undecided → Medium
milestone: none → 0.7.0
summary: - panflue no longer displays album art in notification bubble
+ Panflute no longer displays album art from Banshee
Changed in panflute:
status: Confirmed → Fix Committed
Changed in panflute:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers