PPA doesn't build packages for Karmic

Bug #467275 reported by Vincent on 2009-10-31
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Panflute
Medium
Paul Kuliniewicz
Ppa
Medium
Paul Kuliniewicz

Bug Description

(I would report this against the package in the PPA but I have no idea how to...)

Even though the Jaunty package for 0.5.1 worked fine for me on Karmic, the PPA doesn't build packages for it. I'm not exactly sure how PPA's work, but if it's a matter of clicking a button to have the packages built for other versions of Ubuntu, could you please enable that? :)

Paul Kuliniewicz (kuliniew) wrote :

I'll need to look up how to work with PPAs for multiple releases, but it shouldn't be an issue. As you saw, the packages themselves should install just fine on Karmic.

Changed in panflute:
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Paul Kuliniewicz (kuliniew)
Vincent (vinnl) wrote :

Yeah, only now I have to manually download it each time instead of receiving the updates automatically through the package manager, because I get an error whenever I reload my repo's with the PPA enabled.

Paul Kuliniewicz (kuliniew) wrote :

The guidance at https://help.launchpad.net/Packaging/PPA/Uploading#Using%20packages%20from%20other%20distributions for uploading the same source package to multiple distributions (i.e. jaunty and karmic) doesn't seem to be working for me. The easiest way forward will probably be to release a 0.5.3 this weekend that fixes an additional bug or two, and also happens to let me switch versioning schemes for PPA releases to use separate numbers for jaunty and karmic.

I've never used PPA for distribution myself, but as far as I know the "Using packages from other distributions" (linked above) has nothing to do with this problem. Rather, it's a question of packaging, specifically the changelog bit (https://wiki.ubuntu.com/PackagingGuide/Complete#changelog) wherein the dist is given.

Paul Kuliniewicz (kuliniew) wrote :

Yeah, rereading that now, I see it's talking about uploading a source package from a different, non-Ubuntu, Debian-based distro (e.g. Debian unstable) and being able to manually tell it which Ubuntu suite (e.g. jaunty or karmic) to build it for. If you upload a source package that is for a particular Ubuntu suite, it'll use whatever's in changelog no matter what. That explains why the override wasn't working.

Changed in panflute:
milestone: none → 0.5.3-ppa1
Changed in panflute:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions