openal sound gets cut off at end

Bug #422427 reported by Thomas Busch
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Panda3D
Fix Released
High
gogg

Bug Description

when playing a 44.1KHz, 16Bit mono sound that is between 5 - 8 seconds long, it get's cut off at the end, this has probably to do with some buffer size, as sounds that are longer are streamed (and play fine then).

panda-version: 1.6.2
operating-systems: winXP/Vista, Ubuntu Jaunty, all 32Bit

Revision history for this message
rdb (rdb) wrote : Re: [Bug 422427] [NEW] openal sound gets cut off at end

Can you attach a sound file that clearly shows the problem, and some sample
code to play it?

On Tue, Sep 1, 2009 at 10:12 AM, Thomas Busch <email address hidden> wrote:

> Public bug reported:
>
> when playing a 44.1KHz, 16Bit mono sound that is between 5 - 8 seconds
> long, it get's cut off at the end, this has probably to do with some
> buffer size, as sounds that are longer are streamed (and play fine
> then).
>
> panda-version: 1.6.2
> operating-systems: winXP/Vista, Ubuntu Jaunty, all 32Bit
>
> ** Affects: panda3d
> Importance: Undecided
> Status: New
>
> --
> openal sound gets cut off at end
> https://bugs.launchpad.net/bugs/422427
> You received this bug notification because you are subscribed to
> Panda3D.
>

Revision history for this message
Thomas Busch (thbusch) wrote :

here is some code that reproduces the issue (basically taken from the manual):

  import direct.directbase.DirectStart

  mysound = loader.loadSfx("Testfile.wav")
  mysound.play()
  run()

i have attached a soundfile that plays not to the end.

rdb (rdb)
Changed in panda3d:
status: New → Confirmed
gogg (gogg)
Changed in panda3d:
status: Confirmed → Fix Committed
Revision history for this message
rdb (rdb) wrote :

Picked up for 1.7 branch...

Changed in panda3d:
assignee: nobody → gogg (gogg)
importance: Undecided → High
milestone: none → 1.7.1
rdb (rdb)
Changed in panda3d:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments