Fix for bug 1599771 breaks popup menus

Bug #1649577 reported by Chris Coulson on 2016-12-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Critical
Olivier Tilloy
1.19
Critical
Olivier Tilloy

Bug Description

Whilst trying to bring <select> popup menu support in to UbuntuWebView, I've been struggling to get them working. It turns out that popup menus are also broken in webbrowser-app with Oxide 1.19.

What's happening is:

1) The popup menu opens and receives focus.
2) Blink immediately requests that the popup menu closes because the webview sends a blur event.

This is a regression from bug 1599771. It sucks that we didn't find this sooner (when the UI lives in Oxide, this sort of thing will be easily testable with automated tests in Oxide).

I wonder whether we should revert the fix for bug 1599771 on the 1.19 branch and come up with a different fix for that.

Related branches

Changed in oxide:
importance: Undecided → Critical
status: New → Triaged
milestone: none → branch-1.20
Olivier Tilloy (osomon) wrote :

I can confirm this works in 1.18.5, and is broken in 1.19.5 and in trunk.

Olivier Tilloy (osomon) on 2016-12-13
Changed in oxide:
status: Triaged → Fix Released
assignee: nobody → Olivier Tilloy (osomon)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers