find in page doesn’t wrap correctly

Bug #1640264 reported by Olivier Tilloy on 2016-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Medium
Olivier Tilloy
1.19
Medium
Olivier Tilloy

Bug Description

I’m testing webbrowser-app with a local build of oxide master, and I’m seeing a regression in the find-in-page functionality.
 1) If I browse to e.g. http://start.ubuntu.com, activate find-in-page and search for "ubuntu", I get 3 results, and the first one is highlighted (counter: "1/3")
 2) If I press the next match button, the second match is highlighted (counter: "2/3")
 3) If I press again the next match button, the third match is highlighted (counter: "3/3")
 4) If I press again the next match button, I expect the navigation to wrap, and the first match to be highlighted, but instead no match is highlighted, and the counter remains at "3/3"
 5) If I press again the next match button, the first match is highlighted, and the counter updated to "1/3".

It looks like find-in-page behaves as if there was a fourth phantom match that doesn’t update the counter (at step 4).

I’m not observing this with oxide 1.18.3, so this seems to be a recent regression in oxide master.

Changed in oxide:
status: New → Triaged
importance: Undecided → Medium
milestone: none → branch-1.20
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in oxide:
status: Triaged → In Progress
Changed in oxide:
assignee: Chris Coulson (chrisccoulson) → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) on 2016-11-25
Changed in oxide:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers