Fails to build on trusty

Bug #1638915 reported by Chris Coulson on 2016-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Critical
Chris Coulson
1.19
Critical
Chris Coulson

Bug Description

make[3]: Entering directory `/<<PKGBUILDDIR>>/obj-x86_64-linux-gnu'
/usr/bin/cmake -E cmake_progress_report /<<PKGBUILDDIR>>/obj-x86_64-linux-gnu/CMakeFiles 80
[ 86%] Building CXX object oxide/qt/qmlplugin/CMakeFiles/qmloxideplugin.dir/oxide_qml_plugin.cc.o
cd /<<PKGBUILDDIR>>/obj-x86_64-linux-gnu/oxide/qt/qmlplugin && /usr/bin/x86_64-linux-gnu-g++ -DLEGACY_QMLVALUE_TYPES -DOS_LINUX -DOXIDE_GETTEXT_DOMAIN=\"oxide-qt\" -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_QML_LIB -DQT_QUICK_LIB -Dqmloxideplugin_EXPORTS -std=c++11 -fPIC -I/<<PKGBUILDDIR>>/obj-x86_64-linux-gnu/oxide/qt/qmlplugin -I/<<PKGBUILDDIR>>/oxide/qt/qmlplugin -I/<<PKGBUILDDIR>>/oxide -I/usr/include/qt5/QtCore/5.2.1 -I/usr/include/qt5/QtCore/5.2.1/QtCore -I/usr/include/qt5/QtQml/5.2.1 -I/usr/include/qt5/QtQml/5.2.1/QtQml -I/usr/include/qt5/QtNetwork/5.2.1 -I/usr/include/qt5/QtNetwork/5.2.1/QtNetwork -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/usr/include/qt5/QtQml -I/usr/include/qt5/QtNetwork -I/usr/include/qt5/QtQuick -I/usr/include/qt5/QtGui -I/<<PKGBUILDDIR>>/oxide/qt/core/api/includes -I/<<PKGBUILDDIR>>/oxide/qt/quick/api/includes -fno-rtti -o CMakeFiles/qmloxideplugin.dir/oxide_qml_plugin.cc.o -c /<<PKGBUILDDIR>>/oxide/qt/qmlplugin/oxide_qml_plugin.cc
/usr/bin/cmake -E cmake_progress_report /<<PKGBUILDDIR>>/obj-x86_64-linux-gnu/CMakeFiles
[ 86%] Building CXX object oxide/qt/qmlplugin/CMakeFiles/qmloxideplugin.dir/oxide_qml_download_request.cc.o
cd /<<PKGBUILDDIR>>/obj-x86_64-linux-gnu/oxide/qt/qmlplugin && /usr/bin/x86_64-linux-gnu-g++ -DLEGACY_QMLVALUE_TYPES -DOS_LINUX -DOXIDE_GETTEXT_DOMAIN=\"oxide-qt\" -DQT_CORE_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_QML_LIB -DQT_QUICK_LIB -Dqmloxideplugin_EXPORTS -std=c++11 -fPIC -I/<<PKGBUILDDIR>>/obj-x86_64-linux-gnu/oxide/qt/qmlplugin -I/<<PKGBUILDDIR>>/oxide/qt/qmlplugin -I/<<PKGBUILDDIR>>/oxide -I/usr/include/qt5/QtCore/5.2.1 -I/usr/include/qt5/QtCore/5.2.1/QtCore -I/usr/include/qt5/QtQml/5.2.1 -I/usr/include/qt5/QtQml/5.2.1/QtQml -I/usr/include/qt5/QtNetwork/5.2.1 -I/usr/include/qt5/QtNetwork/5.2.1/QtNetwork -I/usr/include/qt5 -I/usr/include/qt5/QtCore -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++-64 -I/usr/include/qt5/QtQml -I/usr/include/qt5/QtNetwork -I/usr/include/qt5/QtQuick -I/usr/include/qt5/QtGui -I/<<PKGBUILDDIR>>/oxide/qt/core/api/includes -I/<<PKGBUILDDIR>>/oxide/qt/quick/api/includes -fno-rtti -o CMakeFiles/qmloxideplugin.dir/oxide_qml_download_request.cc.o -c /<<PKGBUILDDIR>>/oxide/qt/qmlplugin/oxide_qml_download_request.cc
Linking CXX executable tst_oxideqquicknavigationitem
cd /<<PKGBUILDDIR>>/obj-x86_64-linux-gnu/oxide/qt/tests/unit/oxideqquicknavigationitem && /usr/bin/cmake -E cmake_link_script CMakeFiles/tst_oxideqquicknavigationitem.dir/link.txt --verbose=1
/usr/bin/x86_64-linux-gnu-g++ -std=c++11 -fuse-ld=gold CMakeFiles/tst_oxideqquicknavigationitem.dir/tst_oxideqquicknavigationitem.cc.o CMakeFiles/tst_oxideqquicknavigationitem.dir/tst_oxideqquicknavigationitem_automoc.cpp.o -o tst_oxideqquicknavigationitem -rdynamic ../../../../../chromium/libOxideQtCore.so.0 ../../../../../out/lib/libOxideQtQuick.so.0 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.2.1 /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.2.1 /usr/lib/x86_64-linux-gnu/libQt5Test.so.5.2.1 ../../../../../chromium/libOxideQtCore.so.0 /usr/lib/x86_64-linux-gnu/libQt5Quick.so.5.2.1 /usr/lib/x86_64-linux-gnu/libQt5Gui.so.5.2.1 /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5.2.1 /usr/lib/x86_64-linux-gnu/libQt5Network.so.5.2.1 /usr/lib/x86_64-linux-gnu/libQt5Core.so.5.2.1
../../../../../out/lib/libOxideQtQuick.so.0: error: undefined reference to 'glGenTextures'
../../../../../out/lib/libOxideQtQuick.so.0: error: undefined reference to 'glBindTexture'
../../../../../out/lib/libOxideQtQuick.so.0: error: undefined reference to 'glDeleteTextures'
collect2: error: ld returned 1 exit status
make[3]: *** [oxide/qt/tests/unit/oxideqquicknavigationitem/tst_oxideqquicknavigationitem] Error 1
make[3]: Leaving directory `/<<PKGBUILDDIR>>/obj-x86_64-linux-gnu'
make[2]: *** [oxide/qt/tests/unit/oxideqquicknavigationitem/CMakeFiles/tst_oxideqquicknavigationitem.dir/all] Error 2

Changed in oxide:
milestone: none → branch-1.20
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

And I can't reproduce this locally.

Changed in oxide:
status: Triaged → In Progress
Changed in oxide:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers