tst_WebView_findController.qml fails

Bug #1632487 reported by Chris Coulson on 2016-10-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
High
Chris Coulson

Bug Description

Here is the test log:

********* Start testing of qml-api-test *********
Config: Using QtTest library 5.5.1, Qt 5.5.1 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 5.3.1 20160413)
PASS : qml-api-test::findController::initTestCase()
127.0.0.1 - - [11/Oct/2016 22:44:53] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
PASS : qml-api-test::findController::test_case_insensitive()
127.0.0.1 - - [11/Oct/2016 22:44:54] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
PASS : qml-api-test::findController::test_case_sensitive()
127.0.0.1 - - [11/Oct/2016 22:44:54] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
PASS : qml-api-test::findController::test_change_case_sensitivity()
127.0.0.1 - - [11/Oct/2016 22:44:54] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
PASS : qml-api-test::findController::test_clear()
127.0.0.1 - - [11/Oct/2016 22:44:54] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
PASS : qml-api-test::findController::test_find_non_latin()
127.0.0.1 - - [11/Oct/2016 22:44:54] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
127.0.0.1 - - [11/Oct/2016 22:44:54] code 404, message File not found
127.0.0.1 - - [11/Oct/2016 22:44:54] "GET /tst_invalid_page.html HTTP/1.1" 404 -
PASS : qml-api-test::findController::test_find_on_invalid_page()
PASS : qml-api-test::findController::test_movement()
127.0.0.1 - - [11/Oct/2016 22:44:55] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
PASS : qml-api-test::findController::test_movement_wraps()
127.0.0.1 - - [11/Oct/2016 22:44:55] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
127.0.0.1 - - [11/Oct/2016 22:44:55] "GET /tst_WebView_findControllerManyResults.html HTTP/1.1" 200 -
FAIL! : qml-api-test::findController::test_navigation_does_not_reset() property count
   Actual (): 20
   Expected (): 2
   Loc: [/home/chr1s/src/oxide/master/src/oxide/qt/tests/qmltests/api/tst_WebView_findController.qml(138)]
PASS : qml-api-test::findController::test_new_text_resets_count()
127.0.0.1 - - [11/Oct/2016 22:45:00] "GET /tst_WebView_findController.html HTTP/1.1" 200 -
PASS : qml-api-test::findController::test_not_found_resets_count()
PASS : qml-api-test::findController::cleanupTestCase()
Totals: 12 passed, 1 failed, 0 skipped, 0 blacklisted

The issue is that since https://chromium.googlesource.com/chromium/src.git/+/3ac612d592cd42355a432c8d307051d299d79768, Chromium updates the find-in-page state whenever a frame is added, removed or navigated but the failing test is explicitly testing that this doesn't happen.

The new behaviour looks desirable to me, so I'm just wondering if there's any specific reason why this failing test exists.

Changed in oxide:
importance: Undecided → High
status: New → Triaged
Changed in oxide:
milestone: none → branch-1.19
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in oxide:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers