webbrowser-app: new tab view fills entire window, covering chrome

Bug #1625484 reported by Olivier Tilloy on 2016-09-20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Chris Coulson
Chris Coulson

Bug Description

I’m testing lp:webbrowser-app on desktop with oxide built from trunk (https://git.launchpad.net/oxide/commit/?id=41e9aa7), and when I open a new tab (either clicking the "+" button in the tabs bar or with the Ctrl+T keyboard shortcut) the new tab view (which is anchored to fill its parent webview) takes up the entire window, covering the chrome.

This is a regression compared to the currently released version (1.17.7-0ubuntu0.16.04.1).

From this new tab view, selecting one of the top sites loads it, and the webview appears to be resized to its expected size as soon as loading starts. So it looks like the view is not sized correctly until it loads something.

Changed in oxide:
importance: Undecided → High
status: New → Triaged
milestone: none → branch-1.19
Changed in oxide:
assignee: nobody → Chris Coulson (chrisccoulson)
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :
Changed in oxide:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers