Building oxide in debug mode does not run webbrowser

Bug #1625122 reported by Andrew Hayzen on 2016-09-19
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
High
Chris Coulson
1.17
High
Chris Coulson
1.18
High
Chris Coulson

Bug Description

What happened:
1) Branched oxide's code
2) Built in debug mode (cmake ../ -DCMAKE_BUILD_TYPE=Debug)
3) Run trunk of the webbrowser (./out/bin/run_qmlapp.sh --debug path/to/webbrowser-app)
4) Inside gdb start the webbrowser and notice as it is launching that is crashes

What I expected to happen:
When launching the webbrowser with oxide in debug mode for it not to crash.

Output in gdb where it crashes - http://pastebin.ubuntu.com/23202310/
After running 'bt' in gdb - http://pastebin.ubuntu.com/23202297/

Chris Coulson (chrisccoulson) wrote :

I can't reproduce this

Chris Coulson (chrisccoulson) wrote :
Changed in oxide:
importance: Undecided → High
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
milestone: none → branch-1.19
assignee: Chris Coulson (chrisccoulson) → nobody
status: Triaged → Fix Released
assignee: nobody → Chris Coulson (chrisccoulson)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers