Renderer crashes in yakkety: "The rendering process has been closed for this tab"

Bug #1618589 reported by Chris Coulson on 2016-08-30
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Oxide
High
Chris Coulson
1.16
Undecided
Unassigned
1.17
High
Chris Coulson

Bug Description

The renderer crashes reliably shortly after navigating to news.google.com:

Received signal 11 SEGV_MAPERR 000000000028
#0 0x7f766de0cb9e base::debug::StackTrace::StackTrace()
#1 0x7f766de0cf59 base::debug::(anonymous namespace)::StackDumpSignalHandler()
#2 0x7f76720f9670 <unknown>
#3 0x7f76703de845 blink::LayoutObject::isDescendantOf()
#4 0x7f7670459f3c blink::CompositedLayerMapping::containingSquashedLayer()
#5 0x7f7670461345 blink::CompositingLayerAssigner::getReasonsPreventingSquashing()
#6 0x7f767046229e blink::CompositingLayerAssigner::assignLayersToBackingsInternal()
#7 0x7f7670461fa1 blink::CompositingLayerAssigner::assignLayersToBackingsInternal()
#8 0x7f7670461fa1 blink::CompositingLayerAssigner::assignLayersToBackingsInternal()
#9 0x7f7670462381 blink::CompositingLayerAssigner::assign()
#10 0x7f7670466679 blink::PaintLayerCompositor::updateIfNeeded()
#11 0x7f7670467b3e blink::PaintLayerCompositor::updateIfNeededRecursiveInternal()
#12 0x7f7670467d7c blink::PaintLayerCompositor::updateIfNeededRecursive()
#13 0x7f767006a999 blink::FrameView::updateLifecyclePhasesInternal()
#14 0x7f76701d5fcd blink::PageAnimator::updateAllLifecyclePhases()
#15 0x7f766f632a7c blink::WebViewImpl::updateAllLifecyclePhases()
#16 0x7f766e969c1a cc::ProxyMain::BeginMainFrame()
#17 0x7f766e973793 _ZN4base8internal7InvokerINS0_9BindStateIMN2cc9ProxyMainEFvSt10unique_ptrINS3_28BeginMainFrameAndCommitStateESt14default_deleteIS6_EEEJNS_7WeakPtrIS4_EENS0_13PassedWrapperIS9_EEEEEFvvEE3RunEPNS0_13BindStateBaseE
#18 0x7f766de0e5c0 base::debug::TaskAnnotator::RunTask()
#19 0x7f766f42df7f blink::scheduler::TaskQueueManager::ProcessTaskFromWorkQueue()
#20 0x7f766f42e5c5 blink::scheduler::TaskQueueManager::DoWork()
#21 0x7f766de0e5c0 base::debug::TaskAnnotator::RunTask()
#22 0x7f766de2d85a base::MessageLoop::RunTask()
#23 0x7f766de2eaad base::MessageLoop::DeferOrRunPendingTask()
#24 0x7f766de2ef50 base::MessageLoop::DoWork()
#25 0x7f766de2fbb9 base::MessagePumpDefault::Run()
#26 0x7f766de48f9a base::RunLoop::Run()
#27 0x7f766f1d7352 content::RendererMain()
#28 0x7f766de05124 content::RunZygote()
#29 0x7f766de0569f content::ContentMainRunnerImpl::Run()
#30 0x7f766ddfe421 content::ContentMain()
#31 0x7f766effc00e oxide::OxideMain()
#32 0x7f766cbf2bdf oxide::qt::OxideMain()
#33 0x56343917dfe7 main
#34 0x7f766b4343f1 __libc_start_main
#35 0x56343917e23a _start
  r8: 0000000000000310 r9: 0000000000000000 r10: 0000000000000000 r11: 00000741c04041c0
 r12: 00001cd0e9c92298 r13: 0000000000000007 r14: 0000000000000000 r15: 00007fff9ebfbf50
  di: 0000000000000000 si: 00000f99bc390f00 bp: 0000000000000000 bx: 0000000000000000
  dx: 0000000000000007 ax: 00000f99bc308fc0 cx: 00000000000003b2 sp: 00007fff9ebfbc18
  ip: 00007f76703de845 efl: 0000000000010287 cgf: 0000000000000033 erf: 0000000000000004
 trp: 000000000000000e msk: 0000000000000000 cr2: 0000000000000028
[end of stack trace]

This is yakkety-specific - the exact same source compiled on xenial or vivid/overlay doesn't have this issue.

summary: - Renderer crashes in yakkety
+ Renderer crashes in yakkety: "The rendering process has been closed for
+ this tab"
Chris Coulson (chrisccoulson) wrote :
Changed in oxide:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
milestone: none → branch-1.18
status: New → Fix Released
Chris Coulson (chrisccoulson) wrote :

Not going to fix this for 1.16, as it needs a different change and 1.17 is less than a fortnight away from being the next stable update.

Chris Coulson (chrisccoulson) wrote :

There are 1.17 builds building in https://launchpad.net/~oxide-builds/+archive/ubuntu/oxide-next/ with this workaround

Alberto Mardegan (mardy) wrote :

I just tried oxide 1.17.6-0ubuntu1~ppa and it doesn't fix bug 1613670, which you marked as a duplicate of this bug.

But I believe that the bugs are unrelated, as in bug 1613670 there's no crash. I investigated that bug a little more, I'll a comment there.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.