Web browser can't browse anything - "The rendering process has been closed for this tab" [signal 4 ILL_ILLOPN]

Bug #1613258 reported by Timo Jyrinki on 2016-08-15
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
Oxide
Critical
Chris Coulson
1.16
Critical
Chris Coulson
1.17
Critical
Chris Coulson
glibc (Ubuntu)
Critical
Unassigned
oxide-qt (Ubuntu)
Critical
Unassigned

Bug Description

This is happening with a no-change rebuild of webbrowser-app, with the most likely candidate for the problem trigger being the new glibc 2.24 in yakkety-proposed.

---
https://launchpadlibrarian.net/279047362/buildlog_ubuntu-yakkety-i386.webbrowser-app_0.23+16.10.20160803.1-0ubuntu2_BUILDING.txt.gz

Changed in glibc (Ubuntu):
importance: Undecided → Critical
Olivier Tilloy (osomon) wrote :

The failure appears to be in oxide itself. Have you done a rebuild of oxide against the new glibc?

Timo Jyrinki (timo-jyrinki) wrote :

No, this was just an observation of a webbrowser-app rebuild. But at the time of when I reported this bug, there already was a new oxide-qt built in yakkety which was built against the new glibc.

Olivier Tilloy (osomon) wrote :

Timo confirms that a simple Oxide webview in qmlscene exhibits the same issue with yakkety-proposed, so it’s not a webbrowser-app issue.

affects: webbrowser-app (Ubuntu) → oxide
Olivier Tilloy (osomon) wrote :

This appears to be the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1366894.

Changed in oxide:
status: New → Confirmed
Changed in glibc (Ubuntu):
status: New → Invalid
Changed in oxide:
status: Confirmed → Triaged
milestone: none → branch-1.18
assignee: nobody → Chris Coulson (chrisccoulson)
Chris Coulson (chrisccoulson) wrote :

There's a couple of issues here:

- The new glibc defines MADV_FREE which Chromium detects at compile-time and results in a runtime dependency on it. However, this was only added to linux 4.5.
- The seccomp sandbox doesn't allow madvise(MADV_FREE), which is likely what this crash is.

Changed in glibc (Ubuntu):
status: Invalid → Triaged
Changed in oxide:
status: Triaged → In Progress
summary: - signal 4 ILL_ILLOPN in webbrowser-app tests (glibc upgrade?)
+ Web browser can't browse anything - "The rendering process has been
+ closed for this tab" [signal 4 ILL_ILLOPN]
tags: added: unity8-desktop
Chris Coulson (chrisccoulson) wrote :

Marking the glibc task as invalid (see IRC conversation)

<chrisccoulson> does the kernel in yakkety support MADV_FREE?
<apw> chrisccoulson, that is documented as 4.5+ so we will, and currently don't
<chrisccoulson> apw, ah thanks. See bug 1613258 for context - the new glibc defines MADV_FREE
<apw> chrisccoulson, that may have been built with the 4.6 which was in -proposed for a time (glibc)
<apw> that said, i am supprised that glibc is assuming it can use it
 infinity, ^
<apw> chrisccoulson, oh but it is likely the seccomp bits right? so just a profile change ?
 chrisccoulson, in the sense it is resonable for glibc to define it, and the kernel to return EINVAL or indeed work, but we need the seccomp profile to reflect that possibility
<chrisccoulson> apw, we'll probably end up doing the same as http://code.qt.io/cgit/qt/qtwebengine-chromium.git/commit/?h=49-based&id=b12ffcd411d4776f7120ccecb3be34344d930d2b
<apw> chrisccoulson, wouldn't it make more sense to try MADV_FREE and if it fails ENOSUPPORT or whatever dropback to whatever it does when it doesn't have _FREE ?
<apw> so one uses it in 4.5 and not before that all shiney and automatically
<chrisccoulson> apw, we could probably do that

Changed in glibc (Ubuntu):
status: Triaged → Invalid
Daniel van Vugt (vanvugt) wrote :

What's the Ubuntu package name we're expecting a fix in?

Olivier Tilloy (osomon) wrote :

The source package is oxide-qt.

Changed in oxide-qt (Ubuntu):
importance: Undecided → Critical
status: New → Triaged
Changed in oxide:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oxide-qt - 1.16.9-0ubuntu1

---------------
oxide-qt (1.16.9-0ubuntu1) yakkety; urgency=medium

  * Update to v1.16.9
    - Fix LP: #1601887 - Add a quirk to assume that the native orientation of
      the primary screen on freiza and cooler devices is landscape
    - Fix LP: #1613258 - Avoid a hard runtime dependency on MADV_FREE when
      compiled against glibc 2.24, and ensure madvise(MADV_FREE) is allowed
      in the seccomp policy so that it works when the kernel is upgraded to 4.5
    - Fix LP: #1616132 - Explicitly whitelist accelerated canvas and GPU
      raster on various devices. This got disabled due to a recent change
      in libhybris

 -- Chris Coulson <email address hidden> Wed, 24 Aug 2016 16:46:54 +0100

Changed in oxide-qt (Ubuntu):
status: Triaged → Fix Released
Daniel van Vugt (vanvugt) wrote :

Now starts up and appears to work fine, but then fails again soon after loading 'news.google.com' ...

  The rendering process has been closed for this tab

Olivier Tilloy (osomon) wrote :

@Daniel: are you seeing anything useful in the app’s logs?
Any crash file?

Jeremy Bicha (jbicha) wrote :

I can confirm that the browser tab crashes soon after loading news.google.com with current yakkety amd64 live iso.

Chris Coulson (chrisccoulson) wrote :

That seems to be a different bug

Chris Coulson (chrisccoulson) wrote :

The new bug is bug 1618589. Would be great if someone could investigate that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.