hide selection handle when start typing

Bug #1590776 reported by Bill Filler on 2016-06-09
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Oxide
High
Olivier Tilloy
1.15
High
Olivier Tilloy
1.16
High
Olivier Tilloy
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

we are showing the selection handle (in addition to the cursor) whenever entering a text field that already has text in it. For example, if you are replying to a Gmail message, you have an annoying blue selection handle blinking where you are trying to type and you can't turn it off. Or on a form, focusing on a field to append text will also show the selection handle. Or a multi line text area, adding a new line and typing at the beginning.

Tested Chrome on Android and it behaves differently, and think we should do similar:
 1. Show the selection handle initially, but have it disappear when you press any key (space, character, etc.)
 2. Tapping anywhere in the field will cause handle to be shown again
 3. Also, can we put the selection handle on the bottom of the cursor instead of the top? This is the behavior on Chrome for Android and the rest of our non-html platform in Ubuntu touch.

Bill Filler (bfiller) on 2016-06-09
Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: none → 12
assignee: nobody → Bill Filler (bfiller)
importance: Undecided → High
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

TouchSelectionControllerClientAura::EnvPreTargetHandler is relevant: it listens to key, mouse and scroll events, and hides the insertion handle as soon as one of those events is registered.

ui::EventTarget is not used in oxide though, so we’d need to monitor input events at a different level.

Changed in oxide:
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Olivier Tilloy (osomon)
Olivier Tilloy (osomon) wrote :
Changed in oxide:
status: Confirmed → In Progress
milestone: none → branch-1.17
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Olivier Tilloy (osomon) on 2016-06-16
Changed in oxide:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: 12 → 13
Pat McGowan (pat-mcgowan) wrote :

Whats the current plan for landing oxide 1.16 or 1.17?

Changed in canonical-devices-system-image:
assignee: Bill Filler (bfiller) → David Barth (dbarth)
Olivier Tilloy (osomon) wrote :

Oxide 1.16.8 is in silo 34 and being tested now.

Has this feature landed yet? Because I tried with today's image from rc-proposed channel, and I don't find it. :)

Olivier Tilloy (osomon) wrote :

This is targeted at OTA-13, which hasn’t been released yet.

Yes, I know that OTA-12 hasn't been released yet. My question is about the rc-proposed channel. :) As I see Oxide 1.16.8 was released on 23th of August in this image: http://people.canonical.com/~lzemczak/landing-team/ubuntu-touch/rc-proposed/bq-aquaris.en/krillin/413.commitlog

Olivier Tilloy (osomon) wrote :

OTA-12 is the current stable image. The upcoming one is OTA-13.

oxide 1.16.8 has indeed landed in the rc-proposed channel, so this fix is available if you’re using this channel.

Oh, I think I got it now. Yes, it hides the selection handle if it's "closed". If it's "open", so the Copy/Paste items are visible, it doesn't hide them, if If I start typing. Plus as I see it doesn't work at all in the Messaging app. By the way, thanks for your answers and the feature too of course. :)

Olivier Tilloy (osomon) wrote :

Well the handle and menu should hide as soon as you start typing, regardless of whether the context menu is open, and that’s what I’m seeing on my krillin running rc-proposed. Can you explain under what circumstances you’re not seeing this?

Note that messaging-app doesn’t use oxide, so that’s a separate issue.

I've attached a video. It is a Nexus4 with the latest rc-proposed image. I opened the Browser, when the menu is closed it disappears if I start typing. But if it's open, it doesn't.

Olivier Tilloy (osomon) wrote :

Thanks for the video Robin. Now I see what you mean. The change in oxide only affects text fields on web pages. The address bar of the browser is implemented differently, using the standard UI toolkit component for text input (and this is consistent with text fields in other apps, like messaging app). If you think the contextual actions should disappear upon user input (I tend to agree), please file a separate bug at https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+filebug. Thanks!

Thanks, I've filled a bug report and sorry for the confusion. :)

https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1616841

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers