OSK not brought up when focusing a text field in a webview opened from newViewRequested

Bug #1582060 reported by freya zhang on 2016-05-16
68
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Critical
David Barth
Oxide
Critical
Chris Coulson
1.14
Critical
Unassigned
1.15
Critical
Unassigned

Bug Description

Information:
current build number: 335
device name: krillin
channel: ubuntu-touch/rc-proposed/bq-aquaris.en
last update: 2016-05-16 10:14:49
version version: 335
version ubuntu: 20160514
version device: 20160329-a9bacdb
version custom: 20160505-975-38-9

Precondition:
1) WiFi connected
2) HERE account ready

Steps:
1.Launch HERE and HERE launches and map displayed.
2. Go to Here Maps Settings -> Sign in.Sign in page displayed.
3.Tap the input box.And check the performance.

Actual result:
The keyboard is not shown.
Expected result:
The keyboard should be shown.

Changed in unity (Ubuntu):
status: New → Invalid
affects: unity (Ubuntu) → unity8 (Ubuntu)
Changed in unity8 (Ubuntu):
status: Invalid → New
Michał Sawicz (saviq) wrote :

Adding webbrowser-app as that's where the webapp container comes from (I think).

affects: unity8 (Ubuntu) → ubuntu-keyboard (Ubuntu)
Dave Morley (davmor2) on 2016-05-16
Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
Michał Sawicz (saviq) on 2016-05-16
Changed in canonical-devices-system-image:
status: New → Confirmed
Dave Morley (davmor2) wrote :

After a bit of digging seems this is the only place it is happening, the input field is running some sort of script so I assume that might be where the issue lies. This can be inspected if you use chromium on desktop and point it too m.here.com.

I have confirmed the bug though.

Olivier Tilloy (osomon) wrote :

I can confirm the issue, which also exists when pointing the browser application to http://here.com.

Olivier Tilloy (osomon) wrote :

I’ve used the inspector to extract the relevant bit of HTML from the login page on my phone, which I’m attaching here.

Olivier Tilloy (osomon) wrote :

I can’t reproduce the issue with just that standalone bit of HTML. The surrounding page and scripts play a part in that issue.

summary: - The keyboard is not shown when entering HERE account.
+ OSK doesn’t pop up on HERE account login page

Interestingly, if I type http://account.here.com in the address bar and validate, the OSK pops up when focusing the username/password fields.

The same happens if I first reproduce the bug per the original instructions, then close the browser app, then open it again. The account page is restored, and focusing the fields pops up the OSK as expected.

Olivier Tilloy (osomon) wrote :

This is not specific to here.com: I can reliably reproduce the issue with a test HTML page that has a hyperlink (with target="_blank") to another page with any input field, e.g.:

<html>
 <body>
  <a href="http://start.ubuntu.com" target="_blank">test</a>
 </body>
</html>

Clicking that link opens a new tab, but focusing the search field in that new tab doesn’t bring up the OSK.

Olivier Tilloy (osomon) wrote :

This seems to be an oxide issue, I can reliably reproduce on my phone with the following minimal QML scene:

import QtQuick 2.4
import com.canonical.Oxide 1.12
WebView {
  id: root
  Component {
    id: webviewFactory
    WebView {
      anchors.fill: parent
    }
  }
  onNewViewRequested: webviewFactory.createObject(root, {"request": request, "visible": true})
  Component.onCompleted: loadHtml('<html><body><a href="http://start.ubuntu.com" target="_blank">test</a></body></html>')
}

Olivier Tilloy (osomon) on 2016-05-18
summary: - OSK doesn’t pop up on HERE account login page
+ OSK not brought up when focusing a text field in a webview opened from
+ newViewRequested
no longer affects: ubuntu-keyboard (Ubuntu)
no longer affects: webbrowser-app (Ubuntu)
Changed in oxide:
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in oxide:
milestone: none → branch-1.16
Chris Coulson (chrisccoulson) wrote :
Changed in oxide:
status: In Progress → Fix Released
Olivier Tilloy (osomon) on 2016-06-08
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
importance: Undecided → Critical
assignee: nobody → David Barth (dbarth)
milestone: none → 12
Bob Harvey (bobharvey) wrote :

Will this also fix bug #1441547 then?

Bob Harvey (bobharvey) wrote :

Or at least fix bug #1588493 ?

Bob Harvey (bobharvey) wrote :

And is it the fix for #1591457 ?

Olivier Tilloy (osomon) wrote :

This doesn’t seem to fix bug #1441547. Will look into that one.
Bug #1588493 is a duplicate of this one indeed.
And bug #1591457 might be a duplicate of this one, please see my comments/question there.

Olivier Tilloy (osomon) on 2016-06-13
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers