can't deselect text after selecting on nytimes.com

Bug #1573620 reported by Bill Filler
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Oxide
High
Santosh
webapps-sprint
High
Santosh
webbrowser-app (Ubuntu)
Medium
Santosh

Bug Description

This occurs on nytimes.com, most other sites works but guessing others will not work as well.

Steps to reproduce:
- go to nytimes.com and click on a news article
- long press and drag the handles to select some text
- tap on another area of the page to deselect the selected text

Expected results:
- selected text should become unselected

Actual results:
- text remains selected

Note, this works correctly in Chrome for iOS

Related branches

Bill Filler (bfiller)
Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
importance: Undecided → High
milestone: none → 11
Olivier Tilloy (osomon)
summary: - can't deselect text after selecting
+ can't deselect text after selecting on nytimes.com
David Barth (dbarth)
Changed in oxide:
assignee: nobody → Santosh (santoshbit2007)
Changed in canonical-devices-system-image:
status: New → Confirmed
Revision history for this message
David Barth (dbarth) wrote :

Note: you need to have all input helpers off, ie spell checker OFF, auto-correct OFF, etc.

Revision history for this message
Olivier Tilloy (osomon) wrote :

@David: wrong bug report? This issue doesn’t seem to be linked to the OSK.

Revision history for this message
David Barth (dbarth) wrote :

Indeed. It was meant for #1448145

David Barth (dbarth)
Changed in webapps-sprint:
milestone: none → sprint-22
assignee: nobody → Santosh (santoshbit2007)
importance: Undecided → High
Changed in oxide:
importance: Undecided → High
status: New → Confirmed
status: Confirmed → Triaged
Changed in webapps-sprint:
status: New → Triaged
Changed in canonical-devices-system-image:
milestone: 11 → 12
David Barth (dbarth)
Changed in webapps-sprint:
status: Triaged → In Progress
Changed in oxide:
status: Triaged → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Revision history for this message
Santosh (santoshbit2007) wrote :

Reason of behaviour :
 When we press down to deselect text, Touch events are send to blink, and gesture event are generated based on whether it is consumed or not.

In this case when touchstart is fired its not handled by webpage, which in turn generate TapDown Gesture, till here fine.
Next TouchEnd event is send to blink which is handled by webpage( i guess by prevent default), which in turn generate TapCancel Gesture event. In this way Actual Tap gesture event is cancelled for this webpage. so the selection controller/selection is not cleared.

From chromium/oxide prespective everything is OK.

I tried to change useragent and check the touchend handler in webpages, seems that with android chrome page is different in which there is not touchend event handler.
Touch handler related page comes for specific useragent such as IPhone, Firefox, and window7 which has different browser engine.

So my take is this issue is due to useragent issue. The page loaded by oxide is written for different browser engines
Apparently, it worked fine in oxide if I changed the useragent of Android chrome or IOS chrome

David Barth (dbarth)
Changed in webapps-sprint:
milestone: sprint-22 → sprint-23
Revision history for this message
Olivier Tilloy (osomon) wrote :

I have verified that with a custom UA string override for mobile.nytimes.com, the issue goes away.
I used an iphone UA string:

   Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3

But I’m guessing that an android one would do just fine, too.

Santosh, would you mind adding such an override to the browser? The relevant file is https://bazaar.launchpad.net/~phablet-team/webbrowser-app/trunk/view/head:/src/Ubuntu/Web/ua-overrides-mobile.js.

Changed in oxide:
status: In Progress → Invalid
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
assignee: nobody → Santosh (santoshbit2007)
importance: Undecided → Medium
Revision history for this message
Santosh (santoshbit2007) wrote : Re: [Bug 1573620] Re: can't deselect text after selecting on nytimes.com

Yes, I am doing that today now

On Thu, Jun 2, 2016 at 2:30 PM, Olivier Tilloy <<email address hidden>
> wrote:

> I have verified that with a custom UA string override for
> mobile.nytimes.com, the issue goes away.
> I used an iphone UA string:
>
> Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X)
> AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334
> Safari/7534.48.3
>
> But I’m guessing that an android one would do just fine, too.
>
> Santosh, would you mind adding such an override to the browser? The
> relevant file is https://bazaar.launchpad.net/~phablet-team/webbrowser-
> app/trunk/view/head:/src/Ubuntu/Web/ua-overrides-mobile.js.
>
> ** Changed in: oxide
> Status: In Progress => Invalid
>
> ** Also affects: webbrowser-app (Ubuntu)
> Importance: Undecided
> Status: New
>
> ** Changed in: webbrowser-app (Ubuntu)
> Status: New => Confirmed
>
> ** Changed in: webbrowser-app (Ubuntu)
> Assignee: (unassigned) => Santosh (santoshbit2007)
>
> ** Changed in: webbrowser-app (Ubuntu)
> Importance: Undecided => Medium
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1573620
>
> Title:
> can't deselect text after selecting on nytimes.com
>
> Status in Canonical System Image:
> In Progress
> Status in Oxide:
> Invalid
> Status in webapps-sprint:
> In Progress
> Status in webbrowser-app package in Ubuntu:
> Confirmed
>
> Bug description:
> This occurs on nytimes.com, most other sites works but guessing others
> will not work as well.
>
> Steps to reproduce:
> - go to nytimes.com and click on a news article
> - long press and drag the handles to select some text
> - tap on another area of the page to deselect the selected text
>
> Expected results:
> - selected text should become unselected
>
> Actual results:
> - text remains selected
>
> Note, this works correctly in Chrome for iOS
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1573620/+subscriptions
>

Revision history for this message
Santosh (santoshbit2007) wrote :

I am doing it today,

Revision history for this message
Santosh (santoshbit2007) wrote :
Revision history for this message
David Barth (dbarth) wrote :

Have you tried modifying the string to say "Ubuntu like Android" ? does
that work with this site?
In general, we're trying to keep as much references to Ubuntu as possible,
to keep an option for sites to distinguish between phones and more
officially support Ubuntu.

On Mon, Jun 6, 2016 at 10:54 AM, Santosh <email address hidden>
wrote:

> https://code.launchpad.net/~santoshbit2007/webbrowser-app/webbrowser-
> app/+merge/296521
>
> --
> You received this bug notification because you are a bug assignee.
> https://bugs.launchpad.net/bugs/1573620
>
> Title:
> can't deselect text after selecting on nytimes.com
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1573620/+subscriptions
>

Olivier Tilloy (osomon)
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
Olivier Tilloy (osomon)
Changed in webbrowser-app (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Santosh (santoshbit2007)
Changed in webapps-sprint:
status: In Progress → Fix Committed
David Barth (dbarth)
Changed in webapps-sprint:
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers