Multiple Web Apps crashes when returning from a linked page

Bug #1570828 reported by Dario Cavedon
90
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Oxide
High
Alexandre Abreu
1.18
Undecided
Unassigned
1.19
Undecided
Unassigned
webapps-sprint
High
Alexandre Abreu

Bug Description

This bug seems affect Twitter, Facebook and Gmail Web App, so it could be a webbrowser bug. All of those apps crash when returning from a linked page.

Steps to reproduce:
- Open Twitter/Facebook/Gmail web app
- On the Twitter/Facebook timeline or on an email, tap on a external link (a web page, an article from a magazine, ...)
- A new external page pops up from the bottom
- _Magnify_ the text on the page / article
- Tap the button at the top left to return to Twitter/Facebook/Gmail app
- Twitter/Facebook/Gmail crashes instantly.

When you restart the crashed web app, it starts with the external page / article.

It happens on a Meizu MX4 with OTA 10.1.

Dario Cavedon (dcavedon)
description: updated
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
Changed in webapps-sprint:
milestone: none → sprint-21
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → High
status: New → Confirmed
Changed in webbrowser-app (Ubuntu):
status: Confirmed → In Progress
Changed in webapps-sprint:
status: Confirmed → In Progress
David Barth (dbarth)
Changed in webapps-sprint:
milestone: sprint-21 → sprint-22
David Barth (dbarth)
Changed in webapps-sprint:
milestone: sprint-22 → sprint-23
David Barth (dbarth)
Changed in webapps-sprint:
milestone: sprint-23 → sprint-24
Revision history for this message
Andrea Bernabei (faenil) wrote :

I've been noticing this on Krillin since a few weeks (now I'm on rc-proposed/bq-aquaris.en r388), I had not noticed it before, so maybe it got worse than it was before?

Is there an update about this bug @Alex ?

Revision history for this message
Andrea Bernabei (faenil) wrote :

"free -h" output on my Krillin while running a webapp, crash included

http://pastebin.ubuntu.com/20158255/

Revision history for this message
Andrea Bernabei (faenil) wrote :

I'd like to add some details:
I have not noticed this issue in the past 1year 5months of using Krilling as my daily driver, until a month or so ago.

I believe the system memory usage increased over time to the point of making this bug much more evident since a few weeks (a month? maybe even 2? I'm not sure).

It would be good to give this another push, if possible :)

can we reprioritize it?

Revision history for this message
Andrea Bernabei (faenil) wrote :

"df" output, to show I'm not running out of space or any particular low-disk-space situation

phablet@ubuntu-phablet:~$ df
Filesystem 1K-blocks Used Available Use% Mounted on
udev 489504 4 489500 1% /dev
tmpfs 98372 340 98032 1% /run
/dev/mmcblk0p7 4610128 1607032 2768908 37% /userdata
/dev/mmcblk0p6 2075252 1687672 387580 82% /
/dev/loop0 143940 142136 1804 99% /android/system
none 4 0 4 0% /android
tmpfs 491856 4 491852 1% /etc/fstab
/dev/disk/by-path/platform-mtk-msdc.0-part5 705512 18292 687220 3% /android/cache
none 4 0 4 0% /sys/fs/cgroup
tmpfs 491856 40 491816 1% /tmp
cgmfs 100 0 100 0% /run/cgmanager/fs
none 5120 0 5120 0% /run/lock
none 491856 15856 476000 4% /run/shm
none 102400 0 102400 0% /run/user
tmpfs 491856 0 491856 0% /media
tmpfs 491856 4 491852 1% /var/lib/sudo
tmpfs 98372 44 98328 1% /run/user/32011
tmpfs 98372 0 98372 0% /run/user/0

Revision history for this message
Alexandre Abreu (abreu-alexandre) wrote :
Download full text (4.1 KiB)

here is a stack trace

Thread 1 "webapp-containe" received signal SIGSEGV, Segmentation fault.
0x00007fffda2d3c3c in oxide::(anonymous namespace)::TryDispatchMessageToTarget (target=target@entry=0x0, message=message@entry=0x1252790)
    at ../../../oxide/shared/browser/oxide_script_message_contents_helper.cc:47
47 for (size_t i = 0; i < target->GetScriptMessageHandlerCount(); ++i) {
(gdb) bt
#0 0x00007fffda2d3c3c in oxide::(anonymous namespace)::TryDispatchMessageToTarget (target=target@entry=0x0, message=message@entry=0x1252790)
    at ../../../oxide/shared/browser/oxide_script_message_contents_helper.cc:47
#1 0x00007fffda2d3f53 in oxide::ScriptMessageContentsHelper::OnReceiveScriptMessage (this=<optimized out>, message=..., render_frame_host=<optimized out>)
    at ../../../oxide/shared/browser/oxide_script_message_contents_helper.cc:135
#2 0x00007fffda2d4139 in oxide::ScriptMessageContentsHelper::OnMessageReceived (this=<optimized out>, message=..., render_frame_host=<optimized out>)
    at ../../../oxide/shared/browser/oxide_script_message_contents_helper.cc:159
#3 0x00007fffd75d9f32 in content::WebContentsImpl::OnMessageReceived (this=0x1246a20, render_view_host=0x0, render_frame_host=0x12060d0, message=...)
    at ../../../content/browser/web_contents/web_contents_impl.cc:631
#4 0x00007fffd73a9326 in content::RenderFrameHostImpl::OnMessageReceived (this=0x12060d0, msg=...) at ../../../content/browser/frame_host/render_frame_host_impl.cc:539
#5 0x00007fffd7504a97 in content::RenderProcessHostImpl::OnMessageReceived (this=0xf6b6d0, msg=...) at ../../../content/browser/renderer_host/render_process_host_impl.cc:1772
#6 0x00007fffd9bb9016 in IPC::ChannelProxy::Context::OnDispatchMessage (this=0xe3dd90, message=...) at ../../../ipc/ipc_channel_proxy.cc:284
#7 0x00007fffd928357d in base::Callback<void (), (base::internal::CopyMode)1>::Run() const (this=0x7fffffffd2c8) at ../../../base/callback.h:389
#8 base::debug::TaskAnnotator::RunTask (this=this@entry=0xd2daf0, queue_function=queue_function@entry=0x7fffdad2b7b2 "MessageLoop::PostTask", pending_task=...)
    at ../../../base/debug/task_annotator.cc:51
#9 0x00007fffd92a1cfe in base::MessageLoop::RunTask (this=this@entry=0xd2d970, pending_task=...) at ../../../base/message_loop/message_loop.cc:493
#10 0x00007fffd92a274d in base::MessageLoop::DeferOrRunPendingTask (this=this@entry=0xd2d970, pending_task=...) at ../../../base/message_loop/message_loop.cc:502
#11 0x00007fffd92a2a18 in base::MessageLoop::DoWork (this=0xd2d970) at ../../../base/message_loop/message_loop.cc:624
#12 0x00007fffd6f8977b in oxide::qt::MessagePump::RunOneTask (this=0xd2d730) at ../../../oxide/qt/core/browser/oxide_qt_message_pump.cc:108
#13 0x00007ffff668be53 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#14 0x00007ffff78a505c in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#15 0x00007ffff78aa516 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#16 0x00007ffff665c62b in QCoreApplication::notifyInternal(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#...

Read more...

Revision history for this message
Michael Terry (mterry) wrote :

Poke. Can we please land the proposed fix? It's one of the most annoying Touch bugs right now for me.

Revision history for this message
Cédric Bellegarde (gnumdk) wrote :

Yes, please fix this, all webapps are broken due to this bug...

Revision history for this message
Andrea Bernabei (faenil) wrote :

I agree it's incredibly annoying. Can we get an update on this? :)

Olivier Tilloy (osomon)
affects: webbrowser-app (Ubuntu) → oxide
Revision history for this message
Cesar Herrera (chg1) wrote :

Suppose you enter the app "My Web Apps" and choose a place. If there is a link to another place and you enter it, when you return to the previous place pushing a button down left, perhaps you return or perhaps the program breaks.

Changed in oxide:
milestone: none → branch-1.20
status: In Progress → Fix Released
Revision history for this message
Laryllan (laryllan) wrote :

This bug also affects the desktop webapps, e.g. Google+ and Twitter.
Is there a fix too?

Cheers,
Laryllan

Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
importance: Undecided → High
milestone: none → 15
status: New → In Progress
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers