Select All menu incorrectly display automatically when focus goes to text field

Bug #1560034 reported by Bill Filler on 2016-03-21
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Oxide
High
Olivier Tilloy
1.13
High
Olivier Tilloy
1.14
High
Olivier Tilloy
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

latest rc-proposed
Go to google.com or any web page that has text entry fields

Click in the field

Expected results:
- cursor is displayed

Actual results:
- cursor is displayed and "select all" popup menu is displayed even though the field is blank and nothing has been selected.

The popup menu should not be displayed until the user long presses in the field

Cf bug 1556764 for implementation details.

Bill Filler (bfiller) on 2016-03-21
Changed in webbrowser-app (Ubuntu):
importance: Undecided → High
Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Bill Filler (bfiller)
milestone: none → ww08-2016
description: updated
Olivier Tilloy (osomon) on 2016-03-21
Changed in webbrowser-app (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: New → Confirmed
Olivier Tilloy (osomon) on 2016-03-21
Changed in oxide:
status: New → In Progress
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
milestone: none → branch-1.15
Olivier Tilloy (osomon) on 2016-03-21
Changed in oxide:
status: In Progress → Fix Released
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Invalid
David Barth (dbarth) wrote :

While that bug is fixed, there is still an occasional "Select All" tooltip appearing in empty textfields, in the OA webviews.

Olivier Tilloy (osomon) wrote :

@David: can you describe exactly how this happens?

I’ve seen this happen when focusing an empty text field, typing in some text, then invoking the touch selection menu by long pressing on that text, then clearing it: the touch selection menu remains visible, but I believe this is intentional. If you unfocus that text field and then focus it again, the menu isn’t initially shown, as expected.

Are you seeing a different thing?

Alberto Mardegan (mardy) wrote :

@Olivier: see bug 1559946.

Changed in canonical-devices-system-image:
status: Confirmed → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers