regression: rotating a fullscreen youtube video will give you half the video and half blank screen

Bug #1558792 reported by taiebot65 on 2016-03-17
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Bill Filler
Oxide
Critical
Chris Coulson
1.13
Critical
Chris Coulson
1.14
Critical
Chris Coulson
webbrowser-app (Ubuntu)
High
Olivier Tilloy

Bug Description

rc proposed 15.04 r266
mako

Everything is in the title by rotating a fullscreen youtube video you end up with half white screen half the video

Picture in here http://i.imgur.com/JtLitpt.png

tags: added: regression-proposed
Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww08-2016
status: New → Confirmed
assignee: nobody → Bill Filler (bfiller)
Olivier Tilloy (osomon) on 2016-03-18
Changed in webbrowser-app (Ubuntu):
status: New → Confirmed
assignee: nobody → Olivier Tilloy (osomon)
importance: Undecided → High
Changed in oxide:
importance: Undecided → Critical
milestone: none → branch-1.15
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in canonical-devices-system-image:
status: Confirmed → Triaged
Olivier Tilloy (osomon) on 2016-03-18
Changed in webbrowser-app (Ubuntu):
status: Confirmed → Invalid
Chris Coulson (chrisccoulson) wrote :

This doesn't appear to happen in trunk

Changed in oxide:
status: Triaged → Invalid
Chris Coulson (chrisccoulson) wrote :

The bug occurs in 1.12 as well, so this might be caused by a recent change elsewhere

Chris Coulson (chrisccoulson) wrote :

I think this regressed with http://bazaar.launchpad.net/~oxide-developers/oxide/oxide.trunk/revision/1269, which is in 1.12 as well.

Basically when we rotate, the screen geometry updates occur a bit later than the webview geometry changes, and these don't trigger a resize of the webview compositor (which ignores the webview size in fullscreen mode, to work around a Flash bug)

Chris Coulson (chrisccoulson) wrote :

The underlying problem does still exist in trunk, but it doesn't exhibit this particular symptom because of a change in http://bazaar.launchpad.net/~oxide-developers/oxide/oxide.trunk/revision/1365

Changed in oxide:
status: Invalid → In Progress
Chris Coulson (chrisccoulson) wrote :
Changed in oxide:
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: Triaged → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Mateo Salta (mateo-salta) wrote :

there is a similar problem, where if you go into fullscreen - rotate, then exit fullscreen the non-fullscreen video element is either 1/2 as big - or twice as big depending which orientation you started - is this related? or is there a bug for this?

Olivier Tilloy (osomon) wrote :

@Mateo: I’m not observing this issue with my MX4 neither running the latest rc-proposed nor the latest stable image (OTA 12). Both currently have the same version of oxide (1.15.7).

Could you please file a new bug at https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+filebug with detailed steps to reproduce the issue you’re seeing? Thanks in advance!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers