oxide.qmltypes is invalid when built against Qt5.5

Bug #1532196 reported by Chris Coulson on 2016-01-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Medium
Unassigned

Bug Description

The source tree ships oxide.qmltypes which is generated by a local build and committed to the tree. However, when we build against Qt5.5 some types don't actually exist:

oxide::qmlplugin::DownloadRequest
oxide::qmlplugin::LoadEvent
oxide::qmlplugin::SslCertificate

Related branches

Changed in oxide:
importance: Undecided → Medium
status: New → Triaged
milestone: none → branch-1.13
Olivier Tilloy (osomon) wrote :

Attaching the qmltypes file that a Qt 5.5 build just generated on x86-64. It appears LoadEvent and SslCertificate have simply been moved around in the file. DownloadRequest did disappear though, this needs to be investigated.

Olivier Tilloy (osomon) wrote :

Adding a call to qmlRegisterValueTypeEnums() for OxideQDownloadRequest does the trick, even though that class doesn’t define enums.

Changed in oxide:
assignee: nobody → Olivier Tilloy (osomon)
status: Triaged → In Progress
Changed in oxide:
milestone: branch-1.13 → branch-1.14
Changed in oxide:
milestone: branch-1.14 → branch-1.15
Changed in oxide:
milestone: branch-1.15 → branch-1.16
Changed in oxide:
milestone: branch-1.16 → branch-1.17
Changed in oxide:
milestone: branch-1.17 → branch-1.18
Changed in oxide:
milestone: branch-1.18 → branch-1.19
Changed in oxide:
milestone: branch-1.19 → branch-1.20
Changed in oxide:
milestone: branch-1.20 → branch-1.21
Changed in oxide:
milestone: branch-1.21 → branch-1.22
Changed in oxide:
milestone: branch-1.22 → none
Olivier Tilloy (osomon) on 2018-11-19
Changed in oxide:
status: In Progress → Confirmed
assignee: Olivier Tilloy (osomon) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments