Can't enumerate cameras on the phone

Bug #1508972 reported by Chris Coulson on 2015-10-22
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Oxide
High
Chris Coulson
1.11
High
Chris Coulson
1.12
Undecided
Unassigned
libhybris (Ubuntu)
High
Chris Coulson
qtubuntu-camera (Ubuntu)
Undecided
Ugo Riboni

Bug Description

We recently added a QtMultimedia video capture backend to Oxide so that we can make video capture for WebRTC work on the phone. However, whilst this works fine on desktop, no cameras are detected on the phone because QCamera::availableDevices() returns nothing.

It seems that this functionality hasn't been implemented in qtubuntu-camera (http://bazaar.launchpad.net/~phablet-team/qtubuntu-camera/trunk/view/head:/src/aalcameraserviceplugin.cpp#L43).

Chromium does depend on the ability to enumerate devices, and there's a public facing API for this as well (https://developer.mozilla.org/en-US/docs/Web/API/MediaDevices).

Related branches

Changed in oxide:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: New → Triaged
milestone: none → branch-1.12
Olivier Tilloy (osomon) on 2015-10-22
Changed in qtubuntu-camera (Ubuntu):
status: New → Confirmed
Changed in oxide:
status: Triaged → Fix Released
Chris Coulson (chrisccoulson) wrote :

I worked around this in Oxide with http://bazaar.launchpad.net/~oxide-developers/oxide/oxide.trunk/revision/1238

This is won't fix for 1.11 because of bug 1509256.

Timo Jyrinki (timo-jyrinki) wrote :

Targetting alike to the duplicate bug.

Changed in canonical-devices-system-image:
milestone: none → backlog
assignee: nobody → John McAleely (john.mcaleely)
Changed in canonical-devices-system-image:
assignee: John McAleely (john.mcaleely) → David Barth (dbarth)
importance: Undecided → High
milestone: backlog → ww02-2016
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

This requires a bit of work in libhybris too. Assigned to myself as I'm basically already doing that as part of bug 1441465

Changed in libhybris (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: New → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
David Barth (dbarth) on 2015-12-08
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in libhybris (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
milestone: ww02-2016 → ww08-2016
Ugo Riboni (uriboni) on 2016-02-16
Changed in qtubuntu-camera (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Ugo Riboni (uriboni)
Ugo Riboni (uriboni) wrote :

I got around to properly implement the interfaces in qtubuntu-camera needed for QCameraInfo to work properly.
See https://code.launchpad.net/~uriboni/qtubuntu-camera/cameras-info/+merge/286283

David Barth (dbarth) wrote :

To clarify the work to enable camera support in Oxide and allow WebRTC apps to run is completed.
The additional QCameraInfo task is for other QML apps which want to access phone cameras from a regular Qt API.

Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in qtubuntu-camera (Ubuntu):
status: In Progress → Fix Committed
David Barth (dbarth) on 2016-04-07
Changed in qtubuntu-camera (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers