navigator.vibrate() not supported

Bug #1440863 reported by Alexandre Abreu on 2015-04-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Medium
Alexandre Abreu
webapps-sprint
Medium
Alexandre Abreu

Bug Description

navigator.vibrate() is not currently supported and is not bound to qtfeedback

Related branches

Changed in oxide:
milestone: none → branch-1.8
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → Medium
status: New → Confirmed
description: updated
summary: - navigator.notification.vibrate not supported
+ navigator.vibrate() not supported
Chris Coulson (chrisccoulson) wrote :

How familiar are you with mojo, and have you seen ContentBrowserClient::OverrideRenderProcessHostMojoServices? It looks like it would be possible to use this to override the default devices::VibrartionProvider with our own implementation.

Yes I quickly had a look when I filed the bug to see how feasible it was, found the targeted area, I wasn't familiar w/ mojo but now I am, I saw that you can indeed quickly replace the current impl apparently w/ our own in devices/

Changed in oxide:
milestone: branch-1.8 → branch-1.9
Changed in oxide:
status: Confirmed → In Progress
Changed in oxide:
milestone: branch-1.9 → branch-1.11
Changed in oxide:
milestone: branch-1.11 → branch-1.12
Changed in webapps-sprint:
milestone: none → sprint-17
assignee: nobody → Alexandre Abreu (abreu-alexandre)
importance: Undecided → Medium
status: New → In Progress
Changed in oxide:
milestone: branch-1.12 → branch-1.13
Changed in webapps-sprint:
milestone: sprint-17 → sprint-18
Changed in oxide:
milestone: branch-1.13 → branch-1.14
status: In Progress → Fix Released
Changed in webapps-sprint:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers