pinch-to-unzoom gesture resets zoom level to max in google maps

Bug #1417042 reported by Olivier Tilloy on 2015-02-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
David Barth
Oxide
High
Chris Coulson
1.4
High
Chris Coulson
1.5
High
Chris Coulson

Bug Description

This seems to be a fairly recent regression, although I’m not quite sure when it started happening.

On Ubuntu Touch, in the google maps application (and in the browser app too), the pinch-to-unzoom gesture almost always resets the zoom level to its maximum, effectively making it impossible to zoom out.

This happens both in the latest 14.09-proposed (which has oxide 1.3.5-0ubuntu0.14.10.1~rtm) and in the latest vivid-proposed (which has oxide 1.4.2-0ubuntu1).

Bill Filler (bfiller) wrote :

I am seeing this as well. Once you zoom in, you basically cannot zoom back out making the app unusable. I've witnessed crashes a few times as well trying to restore the zoom level back to normal so I could continue to use the app. I will try to get some crash files

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww09-2015
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

Per Bill’s suggestion, I tested with a UA string override, pretending to be chrome on android, but that didn’t help.

Olivier Tilloy (osomon) wrote :

I have tested with a bunch of older images on flo (Nexus 7).

 - image #203 from the utopic channel (2014-08-21) which has oxide 1.1.1-0ubuntu3 doesn’t exhibit the issue
 - image #243 from the utopic channel (2014-09-17) which has oxide 1.2.0-0ubuntu1 has the issue
 - all images after that seem to have the issue, so it’s not a new problem apparently

That puzzles me: if the issue is that old, we should have spotted it long ago.

I checked and there are no significant changes in webbrowser-app to the default UA or related overrides that might explain the issue.

David Barth (dbarth) wrote :

rtm image #9 on krillin also exposes the problem with the current Google Maps code. I start to suspect a change in their client code which changes the way the touch gesture "heuristics" are working on devices (depending on the SW version, device resolution, etc.)

Also worth noting is that on a nexus 4:

(as stated by Olivier above) image #203 from utopic w/ oxide 1.1.1-0ubuntu3 works fine,

image #203 from utopic w/ oxide 1.2.5-0ubuntu1 does NOT work, and has the issue,

Bill Filler (bfiller) wrote :

Based on the comments it looks clear that it's an Oxide regression. Do we have any more detailed information about what changed between those revisions that might be causing the problem?

David Barth (dbarth) wrote :

While Alex keeps investigating a fix (he got some events to be unfiltered to fix the zoom out case), we observed the following :
- the bug affects Google Maps primarily
- it occurs both in webapp-container and webbrowser-app, ie the container differences don't seem to be the root cause of the issue or to make things worse or better
- this seems to confirm this is between webapps and Oxide/blink

Further we verified that the pinch to zoom/unzoom does not affect other websites: Google Search for example is unaffected, nor does it affect apps like Here Maps nor OpenStreetMap, even if they use a similar interface.

Thus, the issue with events being filtered out erroneously is still related to the particular webapp, ie the HTML5 elements used for its interface, and JS handling code for events management /inside the webapp itself/.

Investigations continue.

Chris Coulson (chrisccoulson) wrote :

This is caused when we get a touch event from Qt before getting an ack for the previous touch event from the renderer, which results in us sending touchend events more than once

Changed in oxide:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
status: New → Triaged
status: Triaged → Fix Released
milestone: none → branch-1.6
Changed in canonical-devices-system-image:
assignee: nobody → David Barth (dbarth)
Changed in canonical-devices-system-image:
milestone: ww09-2015 → ww11-2015
Changed in canonical-devices-system-image:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers