keyboard re-appears in webbrowser after dismissing

Bug #1400372 reported by Bill Filler on 2014-12-08
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Unassigned
Oxide
Undecided
Michael Sheldon
1.6
Undecided
Michael Sheldon
ubuntu-keyboard
Invalid
High
Michael Sheldon
ubuntu-keyboard (Ubuntu)
High
Unassigned
ubuntu-keyboard (Ubuntu RTM)
Undecided
Unassigned

Bug Description

latest rtm build on krillin:

- open gmail webapp
- click on search field underneath the "Inbox" button
- type in a search string into the field that will yeild results
- press the return key on the keyboard to execute the search
- search results are displayed and the keyboard remains visible
- now manually swipe the keyboard close in order to scroll through the search results

Expected results:
- keyboard should stay closed while scrolling

Actual results:
- keyboard becomes visible when start scrolling and can't get it to disappear

Guessing the text field must still have focus and is somehow causing the keyboard to reappear when scrolling, but this shouldn't occur

Bill Filler (bfiller) on 2014-12-08
Changed in ubuntu-keyboard:
assignee: nobody → Michael Sheldon (michael-sheldon)
importance: Undecided → High
Changed in ubuntu-keyboard (Ubuntu):
importance: Undecided → High
Olivier Tilloy (osomon) wrote :

I can reliably reproduce the issue, tentatively confirming for both oxide and ubuntu-keyboard until we investigate and find out where the issue lies.

tags: added: osk
Changed in oxide:
status: New → Confirmed
Changed in ubuntu-keyboard:
status: New → Confirmed

I suspect this might also be part of the cause behind bug 1395775, since we get some similar behaviour there with scrolling making the keyboard reappear (in addition to main issue of the keyboard still being displayed after leaving twitter's compose page).

Bill Filler (bfiller) wrote :

Seeing this issue a lot, not just on gmail. It's quite easy to reproduce. Just load a web page that has a text field and other content. Move cursor into the text field. Swipe the keyboard away. Then try to scroll the page.

Expected result:
- I can start scrolling the page without the keyboard popping back up

Actual result:
- As soon as scrolling starts, the keyboard re-appears.

Seems like the problem is we are not releasing focus correctly on the field when we close the keyboard so that when scrolling starts it thinks it has a new focus event.

summary: - keyboard re-appears in gmail after dismissing
+ keyboard re-appears in webbrowser after dismissing
tags: added: ww07
Bill Filler (bfiller) on 2015-02-25
tags: added: usability
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-keyboard (Ubuntu):
status: New → Confirmed
Olivier Tilloy (osomon) wrote :

Just tested again with oxide built from trunk (revision 1013), the issue is still there.

Changed in oxide:
status: Confirmed → In Progress
assignee: nobody → Michael Sheldon (michael-sheldon)
Changed in ubuntu-keyboard:
status: Confirmed → Invalid
Changed in ubuntu-keyboard (Ubuntu):
status: Confirmed → Invalid
Changed in ubuntu-keyboard (Ubuntu RTM):
status: New → Invalid
Olivier Tilloy (osomon) on 2015-03-30
Changed in oxide:
milestone: none → branch-1.7
Olivier Tilloy (osomon) on 2015-03-30
Changed in oxide:
status: In Progress → Fix Released

Thanks for fixing. :)

2015-04-01 15:55 GMT+02:00 Olivier Tilloy <email address hidden>:

> ** Changed in: oxide/1.6
> Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1395775).
> https://bugs.launchpad.net/bugs/1400372
>
> Title:
> keyboard re-appears in webbrowser after dismissing
>
> Status in the base for Ubuntu mobile products:
> New
> Status in Oxide Webview:
> Fix Released
> Status in Oxide 1.6 series:
> Fix Committed
> Status in Ubuntu Keyboard:
> Invalid
> Status in ubuntu-keyboard package in Ubuntu:
> Invalid
> Status in ubuntu-keyboard package in Ubuntu RTM:
> Invalid
>
> Bug description:
> latest rtm build on krillin:
>
> - open gmail webapp
> - click on search field underneath the "Inbox" button
> - type in a search string into the field that will yeild results
> - press the return key on the keyboard to execute the search
> - search results are displayed and the keyboard remains visible
> - now manually swipe the keyboard close in order to scroll through the
> search results
>
> Expected results:
> - keyboard should stay closed while scrolling
>
> Actual results:
> - keyboard becomes visible when start scrolling and can't get it to
> disappear
>
> Guessing the text field must still have focus and is somehow causing
> the keyboard to reappear when scrolling, but this shouldn't occur
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1400372/+subscriptions
>

Changed in canonical-devices-system-image:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers