The HTML5 video player doesn't resize when switching from landscape to portrait mode

Bug #1373383 reported by Adnane Belmadiaf on 2014-09-24
40
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Oxide
High
Chris Coulson

Bug Description

- Open a YouTube video
- Wait for the video to play
- Rotate the phone to landscape mode, the video player will adjust itself to the new size
- Rotate again to portrait mode, the player will stay in the landscape size

Olivier Tilloy (osomon) wrote :

Testing with oxide 1.2.1, and I’m not able to reproduce the issue. I remember observing it in the past though, I’ll downgrade to 1.2.0 to see if the update fixed it.

Olivier Tilloy (osomon) wrote :

Ok, nevermind my previous comment, I can reproduce the issue with both 1.2.0 and 1.2.1.

I seem to remember that in the past, when I did that the player was not resized, and as a result the page could be scrolled horizontally after doing the orientation switch dance.

It’s not the case anymore: after changing to landscape and then back to portrait, the player isn’t resized back, but the page isn’t scrollable either, which results in the video being cropped on the right.

Changed in oxide:
status: New → Confirmed
John McAleely (john.mcaleely) wrote :

Detailed repro from the duplicated bug:

Can not click on full screen button while playing youtube in landscape.

Steps to reproduce:
- Open youtube video from Video scope.

Go into landscape orientation

- Start playing video.
- The Browser app starts and video will be played.
- Touch the screen, to make control icons visible.
- Click on "Full screen" icon
- Video will be played full screen
- click on Click on "Full screen" icon again to exit full screen mode.
- Video will be displayed in non-full screen mode, but scaling is seems to be off and full screen icon is shifted toward the right edge of the screen, making it inaccessible to the user.

Expected results:
User should be able to click on full screen icon.

Actual results:
User is unable to click on full screen icon.

This works as expected if you stay in portrait mode.

Pat McGowan (pat-mcgowan) wrote :

can you take a look

Changed in oxide:
assignee: nobody → Chris Coulson (chrisccoulson)
importance: Undecided → High
Changed in oxide:
status: Confirmed → Triaged
milestone: none → branch-1.6
Changed in oxide:
status: Triaged → In Progress
Chris Coulson (chrisccoulson) wrote :
Changed in oxide:
milestone: branch-1.6 → branch-1.5
status: In Progress → Fix Released
Mateo Salta (mateo-salta) wrote :

still seems to happen with youtube, in newer oxide versions mx4 ota 12

Olivier Tilloy (osomon) wrote :

@Mateo: I’m not observing this issue with my MX4 neither running the latest rc-proposed nor the latest stable image (OTA 12). Both currently have the same version of oxide (1.15.7).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers