Crash on armhf when starting playback of an embedded video

Bug #1337338 reported by Olivier Tilloy on 2014-07-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Oxide
Critical
Chris Coulson
oxide-qt (Ubuntu)
High
Unassigned

Bug Description

Testing webbrowser-app with the latest oxide built from trunk on a N7, going to youtube.com and trying to play back any video triggers the following crash:

#0 0xaf890cca in content::RenderWidgetHostImpl::WasHidden() ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#1 0xae1c1cca in oxide::RenderWidgetHostView::WasHidden() ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#2 0xae1c1ea6 in oxide::RenderWidgetHostView::~RenderWidgetHostView() ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#3 0xae1c1fd8 in oxide::RenderWidgetHostView::~RenderWidgetHostView() ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#4 0xaf891046 in content::RenderWidgetHostImpl::RendererExited(base::TerminationStatus, int) () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#5 0xaf885e18 in content::RenderViewHostImpl::OnRenderProcessGone(int, int) ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#6 0xaf88c8be in content::RenderViewHostImpl::OnMessageReceived(IPC::Message const&) [clone .part.209] ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#7 0xaf884b96 in content::RenderProcessHostImpl::ProcessDied(bool) ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#8 0xae2053de in base::MessageLoop::RunTask(base::PendingTask const&) ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#9 0xae20596e in base::MessageLoop::DeferOrRunPendingTask(base::PendingTask const&) () from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#10 0xae20779c in base::MessageLoop::DoWork() ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#11 0xae1a34ec in oxide::qt::MessagePump::customEvent(QEvent*) ()
   from /usr/lib/arm-linux-gnueabihf/libOxideQtCore.so.0
#12 0xb6de6064 in QObject::event(QEvent*) ()
   from /usr/lib/arm-linux-gnueabihf/libQt5Core.so.5
#13 0xb60c79a4 in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
   from /usr/lib/arm-linux-gnueabihf/libQt5Widgets.so.5
#14 0xb60cb13a in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/arm-linux-gnueabihf/libQt5Widgets.so.5
Cannot access memory at address 0x2d4ff0e0

Changed in oxide:
milestone: none → branch-1.1
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Chris Coulson (chrisccoulson)
Changed in oxide:
status: Triaged → Fix Released
Olivier Tilloy (osomon) wrote :

Re-opening as I’m still seeing webbrowser-app crash when a renderer process is terminated, with a very similar stacktrace. See e.g. bug #1349510.

Changed in oxide:
milestone: branch-1.1 → none
status: Fix Released → Confirmed
Chris Coulson (chrisccoulson) wrote :

It's the same crash, because the fix hasn't been uploaded in to the distro yet. Adding an Ubuntu task

Changed in oxide-qt (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in oxide:
status: Confirmed → Fix Released
milestone: none → branch-1.1
Olivier Tilloy (osomon) wrote :

Oh, I thought it was in the 1.1.0 release already?

tags: added: qa-daily-testing qa-touch rtm14
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oxide-qt - 1.1.1-0ubuntu3

---------------
oxide-qt (1.1.1-0ubuntu3) utopic; urgency=medium

  * Update to v1.1.1
    - Bump Chromium rev to 37.0.2062.58
    - Fix LP: #1337389 - Make ContentBrowserClient::CanCreateWindow work
      again
    - Fix LP: #1332996 - QtCreator often halts for a minute. Don't crash on
      Qt platforms that don't implement QPlatformNativeInterface. As we can't
      get a native display handle on these platforms, disallow any GL
      implementation in Chromium and guard against accesses to
      BrowserProcessMain::GetNativeDisplay()
  * Build with GCC 4.8 for now because GCC 4.9 breaks web content layout on
    the device, which sucks quite a lot right before RTM
    - update debian/rules
    - update debian/control

oxide-qt (1.1.0-0ubuntu1) utopic; urgency=medium

  * Update to v1.1.0
    - Bump Chromium rev to 37.0.2062.44
    - Fix LP: #1337338 - Don't crash when destroying a visible RWHV, which
      happens when a render process crashes
    - Fix LP: #1337890 - Update the power save blocker to use the Unity API
      on touch devices
    - Fix LP: #1338639 - Don't crash when calling WebView.loadHtml() before
      the webview is fully constructed
 -- Chris Coulson <email address hidden> Thu, 31 Jul 2014 10:41:43 +0100

Changed in oxide-qt (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers