QtCreator often halts for a minute

Bug #1332996 reported by Sam Segers on 2014-06-22
106
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Oxide
Medium
Unassigned
1.1
Medium
Chris Coulson
oxide-qt (Ubuntu)
High
Unassigned
Nominated for Trusty by Timo Jyrinki

Bug Description

When QtCreator re-indexes, it halts all input for a minute. So I can't write code, navigate, ... This is every 10 minutes or so and is very anoying.

General messages then contains:
QML module does not contain information about components contained in plugins.

Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Web
See "Using QML Modules with Plugins" in the documentation.

Automatic type dump of QML module failed.
Errors:
"/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Web
QQmlComponent: Component is not ready

QML module does not contain information about components contained in plugins.

Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Content
See "Using QML Modules with Plugins" in the documentation.

Automatic type dump of QML module failed.
Errors:
"/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Content
QQmlComponent: Component is not ready

QML module does not contain information about components contained in plugins.

Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/CordovaUbuntu.2.8
See "Using QML Modules with Plugins" in the documentation.

Automatic type dump of QML module failed.
Errors:
"/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/CordovaUbuntu.2.8
QQmlComponent: Component is not ready

Warnings while parsing QML type information of /usr/lib/x86_64-linux-gnu/unity8/qml/Dash:
Failed to parse '/usr/lib/x86_64-linux-gnu/unity8/qml/Dash/Dash.qmltypes'.
Error: /usr/lib/x86_64-linux-gnu/unity8/qml/Dash/Dash.qmltypes:82:19: Expected string literal to contain 'Package/Name major.minor' or 'Name major.minor'.
/usr/lib/x86_64-linux-gnu/unity8/qml/Dash/Dash.qmltypes:83:36: Expected array literal with only number literal members.

QML module does not contain information about components contained in plugins.

Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/Extras/Browser
See "Using QML Modules with Plugins" in the documentation.

Automatic type dump of QML module failed.
Errors:
"/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/Extras/Browser
QQmlComponent: Component is not ready

QML module does not contain information about components contained in plugins.

Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Web
See "Using QML Modules with Plugins" in the documentation.

Automatic type dump of QML module failed.
Errors:
"/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Web
QQmlComponent: Component is not ready

QML module does not contain information about components contained in plugins.

Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/com/canonical/Oxide
See "Using QML Modules with Plugins" in the documentation.

Automatic type dump of QML module failed.
Errors:
"/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" crashed.
Arguments: -relocatable com.canonical.Oxide 1.0 /usr/lib/x86_64-linux-gnu/qt5/qml
[0622/184656:ERROR:gl_implementation_osmesa.cc(22)] Failed to load /usr/lib/x86_64-linux-gnu/oxide-qt/libosmesa.so: /usr/lib/x86_64-linux-gnu/oxide-qt/libosmesa.so: kan gedeeld objectbestand niet openen: Bestand of map bestaat niet

So qmlplugindump fails to load /usr/lib/x86_64-linux-gnu/oxide-qt/libosmesa.so as it's not existing.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: liboxideqtcore0 1.0.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.15.0-6.11-generic 3.15.0
Uname: Linux 3.15.0-6-generic x86_64
ApportVersion: 2.14.3-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Sun Jun 22 18:58:16 2014
InstallationDate: Installed on 2012-02-02 (870 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: oxide-qt
UpgradeStatus: Upgraded to utopic on 2014-05-12 (40 days ago)

Sam Segers (sam-sgrs) wrote :
Changed in oxide-qt (Ubuntu):
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High

To be noted, I dont see it using Utopci and Oxide 1.1,

qmlplugindump still has issues with Oxide though, gdb output:

Trying to create object Vector3dAnimation (QQuickVector3dAnimation)
Got Vector3dAnimation (QQuickVector3dAnimation)
Processing objectQQuickVector3dAnimation
  Processing propertytarget
Trying to create object SpringAnimation (QQuickSpringAnimation)
Got SpringAnimation (QQuickSpringAnimation)
Processing objectQQuickSpringAnimation
  Processing propertytarget
Trying to create object WebView (OxideQQuickWebView)

Program received signal SIGSEGV, Segmentation fault.
0x00007fffe45b18e5 in oxide::qt::WebContextAdapter::ensureChromiumStarted() () from /usr/lib/x86_64-linux-gnu/libOxideQtCore.so.0

I also saw an issue while "parsing" the UserScript "qml" visible Oxide type,

Zoltan Balogh (bzoltan) on 2014-07-09
Changed in oxide-qt (Ubuntu):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

This is because qmlplugindump selections the minimal Qt platform, which doesn't implement QPlatformNativeInterface, which we depend on for getting the native display handle

Changed in oxide:
importance: Undecided → Medium
status: New → Triaged
Chris Coulson (chrisccoulson) wrote :

s/selections/selects/

As Chris said, qmlplugindump selects the minimal plugin which doesnt provide the native interface needed by oxide

https://qt.gitorious.org/qt/qtdeclarative/source/30d64fe0b74d848f4434e37c4971d24eeff39fa5:tools/qmlplugindump/main.cpp#L754

I started a branch there:

lp:~abreu-alexandre/oxide/qmlplugindump-crash

which delays a bit the issue, but in the end we might not be able to get rid of it at this point with a simple fix,

Chris Coulson (chrisccoulson) wrote :

Ah, thanks. It turns out that it wasn't too difficult to fix - I've just pushed http://bazaar.launchpad.net/~oxide-developers/oxide/oxide.trunk/revision/657 which seems to allow it to start up ok

Changed in oxide:
milestone: none → branch-1.2
status: Triaged → Fix Released
Changed in oxide-qt (Ubuntu):
assignee: Zoltan Balogh (bzoltan) → nobody
Download full text (5.5 KiB)

Wouldn't it also be better for Ubuntu's qml plugins to have the typeinfo
included in the plugin? Then qtcreator wouldn't have to execute qmldump
every time.
Op 9-jul.-2014 22:31 schreef "Chris Coulson" <email address hidden>:

> ** Changed in: oxide
> Milestone: None => branch-1.2
>
> ** Also affects: oxide/1.1
> Importance: Undecided
> Status: New
>
> ** Changed in: oxide/1.1
> Milestone: None => 1.1.0
>
> ** Changed in: oxide/1.1
> Importance: Undecided => Medium
>
> ** Changed in: oxide/1.1
> Status: New => Triaged
>
> ** Changed in: oxide
> Status: Triaged => Fix Released
>
> ** Changed in: oxide/1.1
> Assignee: (unassigned) => Chris Coulson (chrisccoulson)
>
> ** Changed in: oxide-qt (Ubuntu)
> Assignee: Zoltan Balogh (bzoltan) => (unassigned)
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1332996
>
> Title:
> QtCreator often halts for a minute
>
> Status in Oxide Webview:
> Fix Released
> Status in Oxide 1.1 series:
> Triaged
> Status in “oxide-qt” package in Ubuntu:
> Confirmed
>
> Bug description:
> When QtCreator re-indexes, it halts all input for a minute. So I can't
> write code, navigate, ... This is every 10 minutes or so and is very
> anoying.
>
> General messages then contains:
> QML module does not contain information about components contained in
> plugins.
>
> Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Web
> See "Using QML Modules with Plugins" in the documentation.
>
> Automatic type dump of QML module failed.
> Errors:
> "/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
> Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Web
> QQmlComponent: Component is not ready
>
>
> QML module does not contain information about components contained in
> plugins.
>
> Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Content
> See "Using QML Modules with Plugins" in the documentation.
>
> Automatic type dump of QML module failed.
> Errors:
> "/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
> Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Content
> QQmlComponent: Component is not ready
>
>
> QML module does not contain information about components contained in
> plugins.
>
> Module path: /usr/lib/x86_64-linux-gnu/qt5/qml/CordovaUbuntu.2.8
> See "Using QML Modules with Plugins" in the documentation.
>
> Automatic type dump of QML module failed.
> Errors:
> "/usr/lib/x86_64-linux-gnu/qt5/bin/qmlplugindump" returned exit code 3.
> Arguments: --path /usr/lib/x86_64-linux-gnu/qt5/qml/CordovaUbuntu.2.8
> QQmlComponent: Component is not ready
>
>
> Warnings while parsing QML type information of
> /usr/lib/x86_64-linux-gnu/unity8/qml/Dash:
> Failed to parse
> '/usr/lib/x86_64-linux-gnu/unity8/qml/Dash/Dash.qmltypes'.
> Error: /usr/lib/x86_64-linux-gnu/unity8/qml/Dash/Dash.qmltypes:82:19:
> Expected string literal to contain 'Package/Name major.minor' or 'Name
> major.minor'.
> /usr/lib/x86_64-linux-gnu/unity8/qml/Dash/Dash.qmltypes:83:36: Expected
> array literal with...

Read more...

Chris Coulson (chrisccoulson) wrote :

I created bug 1341565 for that

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oxide-qt - 1.1.1-0ubuntu3

---------------
oxide-qt (1.1.1-0ubuntu3) utopic; urgency=medium

  * Update to v1.1.1
    - Bump Chromium rev to 37.0.2062.58
    - Fix LP: #1337389 - Make ContentBrowserClient::CanCreateWindow work
      again
    - Fix LP: #1332996 - QtCreator often halts for a minute. Don't crash on
      Qt platforms that don't implement QPlatformNativeInterface. As we can't
      get a native display handle on these platforms, disallow any GL
      implementation in Chromium and guard against accesses to
      BrowserProcessMain::GetNativeDisplay()
  * Build with GCC 4.8 for now because GCC 4.9 breaks web content layout on
    the device, which sucks quite a lot right before RTM
    - update debian/rules
    - update debian/control

oxide-qt (1.1.0-0ubuntu1) utopic; urgency=medium

  * Update to v1.1.0
    - Bump Chromium rev to 37.0.2062.44
    - Fix LP: #1337338 - Don't crash when destroying a visible RWHV, which
      happens when a render process crashes
    - Fix LP: #1337890 - Update the power save blocker to use the Unity API
      on touch devices
    - Fix LP: #1338639 - Don't crash when calling WebView.loadHtml() before
      the webview is fully constructed
 -- Chris Coulson <email address hidden> Thu, 31 Jul 2014 10:41:43 +0100

Changed in oxide-qt (Ubuntu):
status: Confirmed → Fix Released
Timo Jyrinki (timo-jyrinki) wrote :

Since this affects 14.04 LTS users using the SDK, it would be nice to have a backport of the fix to it.

Rick Harris (rickfharris) wrote :

Broken again in 16.04 LTS exactly the same problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers